Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 03:45
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Хранение данных  (Прочитано 4994 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Dresden

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-07-05
  • Сайт: 
  • Профессия: Ученик 1С
Привет всем =)) у меня такой вопрос
у меня есть макет печатной формы, допустим там две колонки 1 и 2, к этой печатной форме есть основная форма с полями для внесения данных, так вот, мне требуется, чтобы значение колонки два на начало дня стало значением колонки 1.
Насколько я понимаю, мне нужно гдето хранить дату и значение колонки 2. так вот где? =)) думал насчет экспорта в txt, но както это криво помоему =)) Спасибо.


Оффлайн Dresden

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-07-05
  • Сайт: 
  • Профессия: Ученик 1С
Re: Хранение данных
« Ответ #1: 06 Июл 2011, 01:21 »
"начало дня"
на начало следующего дня*

Оффлайн Шурыгин Иван Сергеевич

  • забей на все....
  • ****
  • Сообщений: 330
  • РЕПУТАЦИЯ: 82
  • КПД: 25%
  • забей на все!
  • Регистрация: 2011-05-23
  • Сайт: 
  • Профессия: Программист 8.1
Re: Хранение данных
« Ответ #2: 06 Июл 2011, 05:03 »
для таких моментов создан регистр сведений.
===================================
жизнь надо прожить так, чтоб вверху посмотрели.
и сказали "А ну ка повтори"
===================================

Оффлайн Dresden

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-07-05
  • Сайт: 
  • Профессия: Ученик 1С
Re: Хранение данных
« Ответ #3: 06 Июл 2011, 07:18 »
Хм, спасибо, а который из них?
Свой регистр мне врядли разрешат добавить
Можно какой нибудь пример занесения туда данных и обращения к ним?

Оффлайн Шурыгин Иван Сергеевич

  • забей на все....
  • ****
  • Сообщений: 330
  • РЕПУТАЦИЯ: 82
  • КПД: 25%
  • забей на все!
  • Регистрация: 2011-05-23
  • Сайт: 
  • Профессия: Программист 8.1
Re: Хранение данных
« Ответ #4: 06 Июл 2011, 07:43 »
лучше создать свой...
===================================
жизнь надо прожить так, чтоб вверху посмотрели.
и сказали "А ну ка повтори"
===================================

Оффлайн Dresden

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-07-05
  • Сайт: 
  • Профессия: Ученик 1С
Re: Хранение данных
« Ответ #5: 06 Июл 2011, 07:47 »
Дело в том, что я не до конца понимаю всю схему взаимодействия в 1С и учусь на примерах.
Начал писать, но не уверен до конца в том ли направлении.

РегистрПараметры=РегистрыСведений.ЗначенияСвойствОбъектов.СоздатьНаборЗаписей();
Добавление=РегистрПараметры.Добавить();
Дата=ЭлементыФормы.Дата.Значение;
Добавление.Объект.Дата=Дата;

Оффлайн Шурыгин Иван Сергеевич

  • забей на все....
  • ****
  • Сообщений: 330
  • РЕПУТАЦИЯ: 82
  • КПД: 25%
  • забей на все!
  • Регистрация: 2011-05-23
  • Сайт: 
  • Профессия: Программист 8.1
Re: Хранение данных
« Ответ #6: 06 Июл 2011, 09:56 »
в вашем случае набор записей будет не логичен.
лучше использовать такую конструкцию:
МенеджерЗаписи = РегистрСведений.КонтрольМоихЗаписей.СоздатьМенеджерЗаписи();
МенеджерЗаписи.Период = Дата;
МенеджерЗаписи.Данное = ВашеДанное;
МенеджерЗаписи.Записать(Истина);

для реализации такого необходимо добавить новый регистр, периодический, с всего 1 измерением, это данное, типа который вы хотите сохранять.
===================================
жизнь надо прожить так, чтоб вверху посмотрели.
и сказали "А ну ка повтори"
===================================

Оффлайн Dresden

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-07-05
  • Сайт: 
  • Профессия: Ученик 1С
Re: Хранение данных
« Ответ #7: 07 Июл 2011, 01:14 »
Спасибо =))

Оффлайн Dresden

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-07-05
  • Сайт: 
  • Профессия: Ученик 1С
Re: Хранение данных
« Ответ #8: 07 Июл 2011, 03:00 »
Так ну впринципе у меня получилось добавить данные в регистр СОхраненныеНастрйоки, прочитать их, выгрузить в ТаблицуЗначений, но появилась другая проблема.
эта штука хранится в таком виде

|км6дата     |07.07.2011 00:00:00|
|км6остаток|54545                    |

мне требуется сравнить значение км6дата с ТекущейДатой, но не могу догнать как =\\
----------------------------------------
Если Строка.ИмяОбъекта=ТекущаяДата() Тогда
      ОбластьМакета.Параметры.НачалоДня=Строка.ИмяОбъекта;
КонецЕсли;
----------------------------------------
Этот код не работает, поскольку не могу догнать, как идентифицировать именно строку с "км6дата".Ребят, помогите, пожалуйста- уже второй день делаю, а по идее это должно занимать полчаса =\\

Оффлайн Dresden

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-07-05
  • Сайт: 
  • Профессия: Ученик 1С
Re: Хранение данных
« Ответ #9: 07 Июл 2011, 09:15 »
Вот пример с файлом, может, кому нужен. Вопрос с хранением в 1С до сих пор открыт, пока переходит на ручное заполнение.
  СчитатьПараметры = Новый ТекстовыйДокумент;
  ПутьКФайлу="C:\km6_param.txt";
  СчитатьПараметрыФайл = Новый Файл(ПутьКФайлу);

  Если НЕ СчитатьПараметрыФайл.Существует() Тогда
ФайлПараметров=Новый ТекстовыйДокумент;
Дата=Элементыформы.Дата.Значение;
ФайлПараметров.ДобавитьСтроку(Дата);
Остаток=ОбластьМакета.Параметры.КонДня;
ФайлПараметров.ДобавитьСтроку(Остаток);
ФайлПараметров.Записать(ПутьКФайлу);
Иначе


  СчитатьПараметры.Прочитать(ПутьКФайлу);
  ПараметрДата= СчитатьПараметры.ПолучитьСтроку(1);
  ОстатокИзФайла= СчитатьПараметры.ПолучитьСтроку(2);
   ОбластьМакета.Параметры.НачалоДня=ОстатокИзФайла;
   ОбластьМакета.Параметры.КонДня = Число(ОбластьМакета.Параметры.НачалоДня) + Число(Областьмакета.Параметры.Итого);

   Если ПараметрДата=Дата и ОбластьМакета.Параметры.КонДня=ОстатокИзФайла Тогда
Иначе
  Запись=Новый ЗаписьТекста(ПутьКФайлу);
    СчитатьПараметры.УдалитьСтроку(1);
Запись.ЗаписатьСтроку(Дата);
Остаток=ОбластьМакета.Параметры.КонДня;
СчитатьПараметры.УдалитьСтроку(2);
Запись.ЗаписатьСтроку(Остаток);

КонецЕсли;
КонецЕсли;
Вообще, после delphi,php и c++ 1с кажется издевательством над программистом и решением, вставляющим палки в колеса.Хотя фреймворк он и есть фреймворк, или я не прав? =))


Теги:
 

Перенос данных из 1с 82 БП (базовая) в 1с 82 БГУ (базовая)

Автор Владимир87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7438
Последний ответ 06 Дек 2014, 17:40
от дфтын
Поиск по бае данных,(полнотекстовый поиск)

Автор kot_ooРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3884
Последний ответ 19 Май 2014, 15:40
от kot_oo
Как исправить при обновлении ИБ: Ошибка в запросе набора данных по причине: {(58, 2)}: Несовместимые типы "ВЫБОР" <<?>>ВЫБОР

Автор dollРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2114
Последний ответ 01 Янв 2017, 20:27
от Геннадий ОбьГЭС
"Задваивание" данных в отчете

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 13
Просмотров: 7336
Последний ответ 15 Окт 2015, 11:21
от Mari_beginner
Куда сохраняются данные в режиме работы клиент при выгрузке данных обработкой "Универсальный обмен данными в формате XML"

Автор xDDРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 6958
Последний ответ 13 Ноя 2014, 08:23
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
178 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
29 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 184
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal