Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 06:04
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Печать не проведенного документа  (Прочитано 16822 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн AlexxxMKsv

  • *
  • Сообщений: 24
  • РЕПУТАЦИЯ: 1
  • КПД: 4%
  • Регистрация: 2011-02-16
  • Сайт: 
  • Профессия: Ученик 1С
1с Предприятие 7.7
Торговля - Склад редакция 9.2
Оптово-розничная конфигурация 7.70.937

Прошу опишите, как напечатать проведенный документ реализации:
цель зайти в этот документ поменят в поле поставшик продавца, причем у этого продавца заведомо пусто на складе, и не сохраняя и не проводя документ распечатать с новыми продавцом. Сейчас в 1с стоит запрет на печать непроведенного документа.
И дать это разрешение только одному пользователю.


Оффлайн volodya1122

  • ***
  • Сообщений: 215
  • РЕПУТАЦИЯ: 31
  • КПД: 14%
  • Регистрация: 2011-01-24
  • Сайт: 
  • Профессия: Программист 7.7
так всеже проведенного или непроведенного документа? Хотя єто не имеет значения.
1. Ищите в Операции->Константы чтото типа "не печатать непроведенный документ" и измините "да" на "нет" (или что там будет написано).
2. В конфигураторе найти данный документ и в модуле этого документа найти функцию Печать() .Там должно быть чтото типа если Проведен()=1 тогда запретить печатать.....
По видимому конфа правленная, поэтому точно сказать как это у вас реализовано не могу. Ети стороки нужно удалить или лучше закоментировать....
 

Оффлайн prog1c7.7

  • Модератор
  • *****
  • Сообщений: 784
  • РЕПУТАЦИЯ: 260
  • КПД: 33%
  • ну - да , ну - да...
  • Регистрация: 2010-10-20
  • Сайт: 
  • Профессия: Программист 1С
помоему , правильно что правленная конфа (в этом случае)
потому как пользователь хочет поменять что то в проведенном документе уже - видите?
и не проводить..., так не надо, вдруг реквизит учавствует в проведении документа

Оффлайн AlexxxMKsv

  • *
  • Сообщений: 24
  • РЕПУТАЦИЯ: 1
  • КПД: 4%
  • Регистрация: 2011-02-16
  • Сайт: 
  • Профессия: Ученик 1С
Спасибо всем
я сделал так:

Процедура ПоКнопкеПечать(СразуНаПринтер = 0,КолЭкз = 1)
   
   // проверим полномочия печати непроведенных документов
   Если (Проведен()=0)
     Или ((Проведен()=1) И (Модифицированность()=1)) Тогда
      Если глПолучитьПолномочие("РазрешитьПечатьНепроведенныхДокументов") = 0 Тогда
      //Предупреждение("Недостаточно полномочий для печати непроведенного документа!", 60);
      //Возврат;
      ВвестиЧисло(пароль,"Что бы полученить доступ к печати",3,0,10);
      Если пароль <> 111 Тогда
         Предупреждение("Недостаточно полномочий для печати непроведенного документа!", 60);
         Возврат;
        КонецЕсли;
      КонецЕсли;
   КонецЕсли;

   Если  ПустоеЗначение(НомерТекущейФормы) = 1  Тогда
      НомерТекущейФормы = 1;
      Форма.кнПечать.Заголовок(ТаблицаПечФорм.ПолучитьЗначение(НомерТекущейФормы, "Кнопка"));
   КонецЕсли;
   
   Если НомерТекущейФормы = 1  Тогда
      Печать(СразуНаПринтер, КолЭкз);
   Иначе
      Параметры = СоздатьОбъект("СписокЗначений");
      Параметры.ДобавитьЗначение(?((Модифицированность()=0) и (ПустоеЗначение(ТекущийДокумент())=0), ТекущийДокумент(), глВзятьКонтекст(Контекст)), "Контекст");
      Параметры.ДобавитьЗначение(СразуНаПринтер, "Устройство");
      Параметры.ДобавитьЗначение(КолЭкз, "КоличествоКопий");
      
      ОткрытьФорму("Отчет", Параметры, глКаталогПечФорм+ТаблицаПечФорм.ПолучитьЗначение(НомерТекущейФормы,"Файл"));
   КонецЕсли;
   
КонецПроцедуры // ПоКнопкеПечать()

Оффлайн Milkynder

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-01-24
  • Сайт: 
Может уже никому и не нужно... сегодня натолкнулся при создании пользователя на подобную проблему - решается непосредственно через сервис-настройки пользователя - перейти к значениям дополнительных прав пользователя - редактировать права - поставить галочку "печать непроведенных документов".

Оффлайн Herby

  • *****
  • Сообщений: 936
  • РЕПУТАЦИЯ: 164
  • КПД: 18%
  • Регистрация: 2010-08-31
  • Сайт: 
  • Профессия: Программист 7.7
Может уже никому и не нужно... сегодня натолкнулся при создании пользователя на подобную проблему - решается непосредственно через сервис-настройки пользователя - перейти к значениям дополнительных прав пользователя - редактировать права - поставить галочку "печать непроведенных документов".

а это точно к 7.7 относится?

Оффлайн tox

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-08-07
  • Сайт: 
Может уже никому и не нужно... сегодня натолкнулся при создании пользователя на подобную проблему - решается непосредственно через сервис-настройки пользователя - перейти к значениям дополнительных прав пользователя - редактировать права - поставить галочку "печать непроведенных документов".

а это точно к 7.7 относится?
Некропостинг, но столкнулся с подобной проблемой так что мб кто по гуглу тоже зайдёт. Видимо он имел в виду в текущих полномочиях пользователя поставить галочку "печать непроведённых документов", ну или просто сменить полномочия пользователя на полные.

Оффлайн G_Re

  • *
  • Сообщений: 32
  • РЕПУТАЦИЯ: 5
  • КПД: 16%
  • Регистрация: 2011-12-17
  • Сайт: 
  • Профессия: Ученик 1С
Ещё встречается вариант Форма.кнПечать.Доступность(Условие)


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
133 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
62 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 229
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal