Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
19 Июн 2018, 07:32
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как изменить сумму во всех строках табличной части ?  (Прочитано 3310 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн vladus

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-06-28
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте.
Имеется документ, в нем табличная часть, где есть  колонки "Количество", "Цена" и "Сумма".
Сумма = Количество * Цена. Все стандартно.
На форму я добавил флажок, если флажок включен, то к сумме прибавляется  НДС - 13%.
Но флажок применяется лишь к данным текущей строки. Подскажите пожалуйста, как сделать так чтобы
при включении флажка, в колонке "Сумма" изменения происходили по всем строкам, а не по текущим данным.

Вот код:
Процедура Флажок1ПриИзменении(Элемент)
СтрокаТаблЧасти= ЭтаФорма.ЭлементыФормы.ПереченьНоменклатуры.ТекущиеДанные;
Если   Флажок1 = Истина  тогда
СтрокаТаблЧасти.Сумма = (СтрокаТаблЧасти.Сумма / 100 * 13) + СтрокаТаблЧасти.Сумма;
Иначе
СтрокаТаблЧасти.Сумма =  СтрокаТаблЧасти.Цена * СтрокаТаблЧасти.Количество;
КонецЕсли;
КонецПроцедуры

Извените, если вопрос показался слишком простым. Я только начал учить 1С.
Надеюсь на Вашу помощь.
Делай что должен и будь что будет


Оффлайн cannabis_86

  • ***
  • Сообщений: 168
  • РЕПУТАЦИЯ: 19
  • КПД: 11%
  • Регистрация: 2010-08-26
  • Сайт: 
Необходимо использовать цикл:
Для Каждого Строка ИЗ ТабличнаяЧасть1 Цикл
Строка.Реквизит1=Сумма*0.13;
КонецЦикла

Оффлайн vladus

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-06-28
  • Сайт: 
  • Профессия: Ученик 1С
Делай что должен и будь что будет


Теги:
 

"Уникальность" строки таблиной части документа

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 2396
Последний ответ 20 Авг 2014, 12:22
от has
Работа с табличной частью в документе. Или Работа с ШАПКОЙ документа

Автор gorbach178500Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3350
Последний ответ 30 Сен 2011, 20:01
от gorbach178500
УТ 11ред. Есть ли возможность указать серии в заказе покупателя?( в табл. части)

Автор tsaboevРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3468
Последний ответ 02 Июл 2012, 13:11
от totutotam
Применять ПСН относительно доходов, полученных от субаренды части нежилого помещения, нельзя

Автор newsРаздел Новости

Ответов: 0
Просмотров: 798
Последний ответ 23 Июн 2015, 14:25
от news
отчет с анализом данных таб.части и документа + сумма.Расходы из Остатки.Обороты

Автор ilnur75Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 429
Последний ответ 18 Май 2017, 19:12
от ilnur75

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
134 Сообщений
AIFrame AIFrame
124 Сообщений
alexandr_ll
55 Сообщений
alex0402
47 Сообщений
pavl_vs
47 Сообщений
buketov.av buketov.av
43 Сообщений
ilyay ilyay
36 Сообщений
trialex3
24 Сообщений
magnifico61
21 Сообщений
wise wise
15 Сообщений

* Кто онлайн

  • Точка Гостей: 417
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal