Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 04:45
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Подстановка значения реквизита справочника в форму документа  (Прочитано 7012 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн beztrud

Здравствуйте! Есть справочник Сотрудники со стандартным реквизитом "Наименование" - тип Строка и реквизитом "ДатаРождения" - тип Дата. И есть документ "Вводный инструктаж" с реквизитами Наименование - тип Справочник.Ссылка.Сотрудники, ГодРождения - тип Дата. Нужно чтобы при Выборе Сотрудника автоматически заполнялся его ГодРождения в форме документа "Вводный инструктаж". Читал Радченко, но у него написано заполнение табличной части документа. Вот что примерно должно получиться при НаименованиеПриИзменении Объект.ГодРождения=Справочники.Сотрудники.Выбрать(Объект.ГодРождения). Но этот код конечно не верен. Подскажите пожалуйста.


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
У поля ввода "Сотрудник" обрабатываете событие ПриИзменении и пишете:

ГодРождения = Сотрудник.ГодРождения;

Надеюсь мы говорим про 8.1? ;)
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Похоже что 8.2...

Тогда приходится применять Серверную функцию...

&НаСервере
Функция ПолучитьГодРождения(Сотрудник)
Возврат Сотрудник.ГодРождения;
КонецФункции

&НаКлиенте
Процедура НаименованиеПриИзменении(Элемент)
Объект.ГодРождения = ПолучитьГодРождения(Объект.Наименование);
КонецПроцедуры
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн beztrud

У меня 8.2 Процедуру как я понял нужно делать на сервере. Ругается ГодРождения = <<?>>Сотрудник.ГодРождения; (Проверка: Сервер)

Оффлайн beztrud

Спасибо преогромнейшее. Всё работает. Надеюсь я правильно сказал спасибо - нажал "Сказать спасибо"?

Оффлайн Константин5825

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2017-03-06
  • Сайт: 
Похоже что 8.2...

Тогда приходится применять Серверную функцию...

&НаСервере
Функция ПолучитьГодРождения(Сотрудник)
Возврат Сотрудник.ГодРождения;
КонецФункции

&НаКлиенте
Процедура НаименованиеПриИзменении(Элемент)
Объект.ГодРождения = ПолучитьГодРождения(Объект.Наименование);
КонецПроцедуры


Не совсем уловил мысль, можно пожалуйста чуть подробнее? или я что то не понимаю?

У меня есть документ - Заявка на перевозку.
В нем 3 реквизита которые меня щас интересуют.
КонтактКлиента,Телефон,Емайл.

Так же есть справочник - ПредставителиКлиентов с реквизитами КонтактКлиента,Телефон,Емайл.

Я заполняю реквизит в документе выбором нужного мне КонтактаКлиента.

А вот дальше я не могу понять как сделать авто подстановку данных в реквизиты телефон и емайл.

Для КонтактаКлиента делаю событие при изменении на клиенте и сервере.
А с самой процедурой проблемы как не писал все глухо((((

Буду очень признателен за разъяснение!
 

Оффлайн alex0402

  • *****
  • Сообщений: 1193
  • РЕПУТАЦИЯ: 184
  • КПД: 15%
  • Регистрация: 2010-09-10
  • Сайт: 
  • Профессия: Программист 1С
1) Для нового вопроса нужно создавать новую тему, иначе в теме разводится бардак и не понятно кто на что ответил.
2) по сути: контактная информация хранится , скорее всего, в табличной части. Можно получить на сервере перебором т.ч. или запросом из т.ч.
Помощь в л/с $10


Теги:
 

Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 15943
Последний ответ 16 Авг 2012, 12:07
от Will
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7749
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4786
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika
Заполнение столбца табличной части документа по умолчанию и выборка из табличной части.

Автор marshalbratskРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 1588
Последний ответ 25 Май 2016, 19:38
от marshalbratsk
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8525
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 128
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal