Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 10:45
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите с запросом пожалуйсто  (Прочитано 1324 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн mauar

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-10-29
  • Сайт: 
Есть запрос:


    
    ТабличнаяЧасть.Очистить();   
    Запрос=Новый Запрос;
    Запрос.Текст=
    "ВЫБРАТЬ
    |    ПлановыеНачисленияРаботниковСрезПоследних.ФизЛицо,
    |    ПлановыеНачисленияРаботниковСрезПоследних.ВидРасчета,
    |    ПлановыеНачисленияРаботниковСрезПоследних.Показатель1,
    |    ПлановыеНачисленияРаботниковСрезПоследних.Ведомость КАК Ведомость,
    |    ПлановыеНачисленияРаботниковСрезПоследних.Действие КАК Действие,
    |    ПлановыеНачисленияРаботниковСрезПоследних.Период,
    |    ПлановыеНачисленияРаботниковСрезПоследних.ЦФО
    |ИЗ
    |    РегистрСведений.ПлановыеНачисленияРаботников.СрезПоследних КАК ПлановыеНачисленияРаботниковСрезПоследних
    |        ЛЕВОЕ СОЕДИНЕНИЕ РегистрНакопления.ОтработанноеВремяСводный КАК ОтработанноеВремяРабочее
    |        ПО ПлановыеНачисленияРаботниковСрезПоследних.ФизЛицо = ОтработанноеВремяРабочее.ФИЗЛицо
    |            И (ОтработанноеВремяРабочее.ВидУчетаРабВремени.РабочееВремя)
    |            И (НАЧАЛОПЕРИОДА(ОтработанноеВремяРабочее.Период, МЕСЯЦ) = НАЧАЛОПЕРИОДА(&Период, МЕСЯЦ))
    |        ЛЕВОЕ СОЕДИНЕНИЕ РегистрНакопления.ОтработанноеВремяСводный КАК ОтработанноеВремяОтпуск
    |        ПО ПлановыеНачисленияРаботниковСрезПоследних.ФизЛицо = ОтработанноеВремяОтпуск.ФИЗЛицо
    |            И (ОтработанноеВремяОтпуск.ВидУчетаРабВремени = ЗНАЧЕНИЕ(Справочник.КлассификаторИспользованияРабочегоВремени.ОсновнойОтпуск))
    |            И (НАЧАЛОПЕРИОДА(ОтработанноеВремяОтпуск.Период, МЕСЯЦ) = НАЧАЛОПЕРИОДА(&Период, МЕСЯЦ))
    |
    |СГРУППИРОВАТЬ ПО
    |    ПлановыеНачисленияРаботниковСрезПоследних.ФизЛицо,
    |    ПлановыеНачисленияРаботниковСрезПоследних.ВидРасчета,
    |    ПлановыеНачисленияРаботниковСрезПоследних.Показатель1,
    |    ПлановыеНачисленияРаботниковСрезПоследних.Ведомость,
    |    ПлановыеНачисленияРаботниковСрезПоследних.Действие,
    |    ПлановыеНачисленияРаботниковСрезПоследних.Период;
   
    Запрос.УстановитьПараметр("Период", ПериодРегистрации);
    Выборка = Запрос.Выполнить().Выбрать();


 

Получаем дынне так:
Пока Выборка.Следующий() Цикл                        
                    Заполнение=ТабличнаяЧасть.Добавить();
Заполнение.Колонка1     = Выборка.Период;
Заполнение.Колонка2     = Выборка.Период; // вот тут проблема
 

КонецЦикла;



По нему выводится таблица, заполняется так:

 -------------------------------
 | Дата начала| Дата окончания |
 -------------------------------
 | Дата1      | Дата2          |
 -------------------------------
 | Дата2      | Дата3          |
 -------------------------------
 | Дата3      | Дата3+1        |
 -------------------------------

 

надо в правую колонку вывести данные из левой колонки только сместить
её, сделать так чтобы в правую колонку записалась дата из следующей строки левой колонке
Должно в итоге выглядеть так:

 -------------------------------
 | Дата начала| Дата окончания |
 -------------------------------
 | 01.01.2011 |  18.01.2011    |
 -------------------------------
 | 18.01.2011 |  21.01.2011    |
 -------------------------------
 | 21.01.2011 |  22.01.2011    |
 -------------------------------


Оффлайн Шурыгин Иван Сергеевич

  • забей на все....
  • ****
  • Сообщений: 330
  • РЕПУТАЦИЯ: 82
  • КПД: 25%
  • забей на все!
  • Регистрация: 2011-05-23
  • Сайт: 
  • Профессия: Программист 8.1
элементарно Ватсон:
ПерваяСтрока = Истина;
ПерваяДата = Дата(1,1,1);
Пока Выборка.Следующий() Цикл
Если ПерваяСтрока Тогда
НовСтр = ТаблицаПериодов.Добавить();
НовСтр.Период1 = Выборка.Период1;
ПерваяДата = Выборка.Период2;
НовСтр.Период2 = Выборка.Период2;
ПерваяСтрока = Ложь;
Иначе
НовСтр = ТаблицаПериодов.Добавить();
НовСтр.Период1 = ПерваяДата;
НовСтр.Период2 = Выборка.Период2;
КонецЕсли;
КонецЦикла;
===================================
жизнь надо прожить так, чтоб вверху посмотрели.
и сказали "А ну ка повтори"
===================================


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4302
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5559
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5898
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4386
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1985
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
52 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 244
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal