Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 15:23
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Проверка в табличной части  (Прочитано 4106 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн artm81

  • ***
  • Сообщений: 190
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2010-08-03
  • Сайт: 
Здравствуйте!Помогите,пожалуйста,написать обработчик события в следующем примере.В документах ПРОДАЖА И ПОКУПКА ТОВАРОВ в Модулях объекта.При записи(нужно именно при записи!!!) в модуле объекта перебераем строки
табл. части и проверяем, если это не услуга, тогда должно быть
заполнено поле "Серия". Если не заполнено, то не записываем документ.Спасибо.

Структура документа: Есть табличная часть ТОВАРЫ с реквизитами: Номенклатура(Ссылка.Справочник.Номенклатура) (товар,услуга).и есть реквизит СЕРИЯ.


Оффлайн Шурыгин Иван Сергеевич

  • забей на все....
  • ****
  • Сообщений: 330
  • РЕПУТАЦИЯ: 82
  • КПД: 25%
  • забей на все!
  • Регистрация: 2011-05-23
  • Сайт: 
  • Профессия: Программист 8.1
открывайте модуль объекта. создавай предопределенную процедуру ПриЗаписи() и проверяйте что хотите
===================================
жизнь надо прожить так, чтоб вверху посмотрели.
и сказали "А ну ка повтори"
===================================

Оффлайн Винила

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 1
  • КПД: 11%
  • Регистрация: 2011-06-22
  • Сайт: 
  • Профессия: Программист 1С
artm81, как у вас у номенклатуры установлен товары/услуги? (флажок, перечисление, справочник).

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
artm81, как у вас у номенклатуры установлен товары/услуги? (флажок, перечисление, справочник).


Обычно реквизит типа Булево - "Услуга"
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Винила

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 1
  • КПД: 11%
  • Регистрация: 2011-06-22
  • Сайт: 
  • Профессия: Программист 1С
Как то так... но не проверял

Для каждого Строка из ТаблЗнач цикл
Если Строка.Услуги=ложь тогда
Если не ЗначениеЗаполнено(Строка.Серия) тогда
Сообщить("Серия не заполнена в строке "+Строка.НомерСтроки);
Отказ=истина;
Возврат;
КонецЕсли;
КонецЕсли;
КонецЦикла;

ТаблЗнач - табличная часть

Оффлайн crow1983

  • Глобальный модератор
  • *****
  • Сообщений: 438
  • РЕПУТАЦИЯ: 43
  • КПД: 10%
  • Регистрация: 2010-04-26
  • Сайт: 
  • Профессия: Программист 8.1
Корректнее было бы проверку делать ПередЗаписью!!!
Преподаватель, программист...и просто хороший человек

Оффлайн crow1983

  • Глобальный модератор
  • *****
  • Сообщений: 438
  • РЕПУТАЦИЯ: 43
  • КПД: 10%
  • Регистрация: 2010-04-26
  • Сайт: 
  • Профессия: Программист 8.1
И для полного счастья воспользоваться запросом,в котором сразу выбрать НЕ Услуги с пустой Серией. Если результат запроса пустой, то записать документ, если нет то ОТКАЗ + сообщение пользователю.
Преподаватель, программист...и просто хороший человек

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Ну наверное для многострочных табличных частей будет все таки запрос быстрее отрабатывать т.к. перебор всей таб. части займет больше времени...
Я бы например сделал подписку на событие (это как ни как облегчит процедуру обновления)
И я думаю есть смысл проверять не только на услугу номенклатуру, но еще на то, ведется ли вообще для этой номенклатуры серия... А то серии отключены, а пользователь не может провести документ, абсурд)))
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 

"Уникальность" строки таблиной части документа

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1948
Последний ответ 20 Авг 2014, 12:22
от has
Работа с табличной частью в документе. Или Работа с ШАПКОЙ документа

Автор gorbach178500Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3059
Последний ответ 30 Сен 2011, 20:01
от gorbach178500
УТ 11ред. Есть ли возможность указать серии в заказе покупателя?( в табл. части)

Автор tsaboevРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3090
Последний ответ 02 Июл 2012, 13:11
от totutotam
Применять ПСН относительно доходов, полученных от субаренды части нежилого помещения, нельзя

Автор newsРаздел Новости

Ответов: 0
Просмотров: 666
Последний ответ 23 Июн 2015, 14:25
от news
отчет с анализом данных таб.части и документа + сумма.Расходы из Остатки.Обороты

Автор ilnur75Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 248
Последний ответ 18 Май 2017, 19:12
от ilnur75

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
177 Сообщений
ilyay ilyay
69 Сообщений
alex0402
52 Сообщений
oleg-x
48 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal