Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 06:57
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Имитация обработки выбора  (Прочитано 4479 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн dron9205

  • *
  • Сообщений: 27
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-10-11
  • Сайт: 
Здравствуйте. Есть колонка ТП числового типа. Необходимо при активации этой колонки сразу же вызывать обработку выбора поля(стандарный калькулятора для ввода числовых данных). Каким образом это сделать??
Вот так начал:

Процедура ТоварыПриАктивизацииКолонки(Элемент)
   Если Элемент.ТекущаяКолонка.Имя = "Количество" Тогда
      //ТоварыКоличествоНачалоВыбора(Элемент, Истина)   
   КонецЕсли;
КонецПроцедуры

В процедуру НачалоВыбора попадает, но окно выбора не открывает.


Оффлайн dron9205

  • *
  • Сообщений: 27
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-10-11
  • Сайт: 
Процедура ТоварыПриАктивизацииКолонки(Элемент)
   Если Элемент.ТекущаяКолонка.Имя = "Количество" Тогда
      ТоварыКоличествоНачалоВыбора(Элемент, Истина)   
   КонецЕсли;
КонецПроцедуры

Оффлайн dron9205

  • *
  • Сообщений: 27
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-10-11
  • Сайт: 
хоть какие-нибудь мысли есть у кого-нибудь?

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
ну дак покажи процедуру начало выбора?

Оффлайн dron9205

  • *
  • Сообщений: 27
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-10-11
  • Сайт: 
Да ничего там нет. Должна выводить СтандартнаяОбработка выбора...
Или же что туда надо прописать чтобы вызвалось станд. окно выбора числовых значений

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
ну напиши так попробуй в обработке выбора
Перем ВыбЗнач;
СтандартнаяОбработка = Ложь;
Если ВвестиЗначение(ВыбЗнач,"Введи",Новый ОписаниеТипов("Число")) Тогда
Сообщить("Вы ввели: " + ВЫбЗнач);
КонецЕсли;

Оффлайн dron9205

  • *
  • Сообщений: 27
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-10-11
  • Сайт: 
Не так...
Надо чтобы при активации колонки сразу же получилось так:
http://clip2net.com/clip/m73029/1308652281-clip-9kb.png

Оффлайн Шурыгин Иван Сергеевич

  • забей на все....
  • ****
  • Сообщений: 330
  • РЕПУТАЦИЯ: 82
  • КПД: 25%
  • забей на все!
  • Регистрация: 2011-05-23
  • Сайт: 
  • Профессия: Программист 8.1
ну пропиши свою форму, которая как 2 капли воды похожую на калькулятор, и открывай ее)
===================================
жизнь надо прожить так, чтоб вверху посмотрели.
и сказали "А ну ка повтори"
===================================

Оффлайн dron9205

  • *
  • Сообщений: 27
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-10-11
  • Сайт: 
Выкиньте эти ужасный мысли)))

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Можно извратиться вот так))))
Если Элемент.ТекущаяКолонка.Имя = "Количество" Тогда
Shell = Новый COMОбъект("WScript.Shell");
Shell.SendKeys("{F4}");
КонецЕсли;


Теги:
 

Восстановление "убитой" обработки

Автор SuraevРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 7
Просмотров: 6075
Последний ответ 31 Май 2011, 14:27
от Slin
Помогите с созданием обработки "Работа со справочниками"

Автор ИдзумиРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3463
Последний ответ 06 Сен 2012, 15:45
от Идзуми
Открытие управляемой формы из другой формы внешней обработки

Автор YulenkaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 6395
Последний ответ 10 Дек 2015, 11:02
от vitasw
Проблема после запуска обработки "ИзменениеПорядкаУчетаДокументов"

Автор NewbieDinaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 180
Последний ответ 24 Авг 2017, 10:43
от Golickoff
Пропадают начисления отпусков после обработки "Перерасчета зарплаты организации"

Автор bartolomewРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 651
Последний ответ 19 Июл 2016, 10:43
от bartolomew

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
160 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
27 Сообщений
Golickoff Golickoff
27 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 271
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal