Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 17:00
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Оформление строки, 1С:Бухгалтерия 2.0 Платформа 8.2  (Прочитано 5412 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Наталья_Бессонова

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-12
  • Сайт: 
  • Профессия: Программист 1С
Добрый день, уже несколько дней бьюсь надо задачей с целью облегчить свою жизнь.
Я помощник-бухгалтера, посовместительству иногда программирую, больше для интереса.

Задачка такая, создать кнопку которая бы при нажатии выделяла цветом активную строку или если та выделена, то выделение бы снимала.

Создала кнопку, сделала новый реквизит документа типа булево.
Написала код который меняет состояние реквизита с ложь на истину и наоборот.

//вот код
Процедура ДействияФормыПередано(Кнопка, ОформлениеСтроки, ТекСтр)
ДокОбъект = ЭлементыФормы.ДокументСписок.ТекущиеДанные.Ссылка.ПолучитьОбъект();
ДокОбъект.Передано = НЕ ДокОбъект.Передано;
ДокОбъект.Записать(РежимЗаписиДокумента.Запись);
КонецПроцедуры

а вот дальже я села. Понимаю что для оформления строки надо написать процедуру перебора строк с целью определения реквизита ложь или истина.
В Процедуре ДокументСписокПриПолученииДанных(Элемент, ОформленияСтрок)

Дальше не понимаю как и что, подскажите


Оффлайн chuevsf

  • Хочу! Хочу! Хочу! Мышь на палочке!
  • Глобальный модератор
  • *****
  • Сообщений: 1376
  • РЕПУТАЦИЯ: 345
  • КПД: 25%
  • Регистрация: 2010-07-08
    • Skype: chuevsf
  • Сайт: 
  • Профессия: Программист 1С
А почему сразу мышью по строке кликнуть нельзя? Зачем кнопка-то?

Оффлайн Наталья_Бессонова

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-12
  • Сайт: 
  • Профессия: Программист 1С
Если будет клик по строке она будет выделяться и сниматься при открытии документа. а окраска должна быть не по типу выделения,а как отметка о том что документ обработан

Оффлайн Наталья_Бессонова

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-12
  • Сайт: 
  • Профессия: Программист 1С
Вот код работающий если кому интересно. Доработала

    Для Каждого СтрокаОформленияСтрок Из ОформленияСтрок Цикл
       ТекущийДокумент = СтрокаОформленияСтрок.ДанныеСтроки.Ссылка;
       Если СтрокаОформленияСтрок.ДанныеСтроки.Ссылка.Передано = Истина Тогда
          СтрокаОформленияСтрок.ЦветФона =WebЦвета.АкварельноСиний;
          Иначе Если СтрокаОформленияСтрок.ДанныеСтроки.Ссылка.Передано = Ложь Тогда
             СтрокаОформленияСтрок.ЦветФона =WebЦвета.Белый;
         КонецЕсли;
       //МассивДокументов.Добавить(ТекущийДокумент);
       КонецЕсли;
    КонецЦикла;



Тема закрыта

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Для Каждого СтрокаОформленияСтрок Из ОформленияСтрок Цикл
СтрокаОформленияСтрок.ЦветФона = ?(СтрокаОформленияСтрок.ДанныеСтроки.Ссылка.Передано,WebЦвета.АкварельноСиний,WebЦвета.Белый);
КонецЦикла;
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

Обновление конфигурации "Аренда и управление недвижимостью для "1С:Бухгалтерия 8"" с 2.0 на 3.0

Автор Эльвина МуромцеваРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 234
Последний ответ 16 Ноя 2017, 14:26
от Геннадий ОбьГЭС
Как перенести данные из 7.7 типовая УСН 1.3 в 1С 8 типовая бухгалтерия

Автор Александр бухгалтерРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 4845
Последний ответ 13 Фев 2010, 07:58
от Александр бухгалтер
О конфигурации "Бухгалтерия Предприятия 2.0"

Автор СтолярРаздел Закрытые темы

Ответов: 46
Просмотров: 28672
Последний ответ 11 Мар 2012, 18:36
от Котова
Обмен данными Зарплата 8 (бюджет)-Бухгалтерия 8 (бюджет)

Автор VanillaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3229
Последний ответ 14 Дек 2009, 11:16
от Vanilla
Модуль учета спецодежды "Бухгалтерия 2.0"

Автор avtobuhРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 10026
Последний ответ 22 Дек 2011, 07:40
от Slin

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
59 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 313
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal