Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Май 2018, 01:41
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Можно ли просвоить документу конкретного автора?  (Прочитано 2356 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн wmatik

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-28
  • Сайт: 
  • Профессия: Программист 1С
1С Предприятие 7.7(сетевая версия) - 7.70.027,Конф: ПУБ(7.70.010)
Подскажите можно ли присвоить документу конкретного автора?
Я вот написала обработку, которая удаляет автора, а вот можно ли присвоить какого-либо автора?Если можно подскажите как. Вот код обработки:
Процедура Выполнить()   
Док = СоздатьОбъект("документ");
Если Док.НайтиДокумент(ВыбДок)=1 тогда   
сообщить("Автор документа - " + Док.Автор);
Док.Автор = "";
Док.Записать();
сообщить("все!!");
КонецЕсли;
КонецПроцедуры
Спасибо всем кто отклинется


Оффлайн prog1c7.7

  • Модератор
  • *****
  • Сообщений: 784
  • РЕПУТАЦИЯ: 260
  • КПД: 33%
  • ну - да , ну - да...
  • Регистрация: 2010-10-20
  • Сайт: 
  • Профессия: Программист 1С
какого автора? какого захотите? или кто реально создал либо изменил документ?

Оффлайн wmatik

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-28
  • Сайт: 
  • Профессия: Программист 1С
Ну хотелось бы конечно какого угодно пользователя, ну чтобы в коде указывать конкретного пользователя можно было.

Оффлайн wmatik

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-28
  • Сайт: 
  • Профессия: Программист 1С
ну или хотя бы кто создал документ

Оффлайн prog1c7.7

  • Модератор
  • *****
  • Сообщений: 784
  • РЕПУТАЦИЯ: 260
  • КПД: 33%
  • ну - да , ну - да...
  • Регистрация: 2010-10-20
  • Сайт: 
  • Профессия: Программист 1С
Тем же обходом документов воспользуйся, выбери жертву из справочника пользователи и на него покажи.
вопросы?

Оффлайн wmatik

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-28
  • Сайт: 
  • Профессия: Программист 1С
Процедура Сформировать()   
Док = СоздатьОбъект("документ");
Спр = СоздатьОбъект("Справочник.Сотрудники");
Если Док.НайтиДокумент(ВыбДок)=1 тогда   
сообщить("Автор документа - " + Док.Автор);
    Спр.НайтиПоНаименованию("Левчук",1);
Если Спр.Выбран()>0 Тогда
Фамилия=Спр.Фамилия;
Сообщить(Спр.Фамилия);
КонецЕсли;
Док.Автор = "Левчук";
Сообщить(Спр.Фамилия);
Док.Записать();
сообщить("все!!");
КонецЕсли;
КонецПроцедуры
Не присваивает, просто убирает автора и все, пустая ячейка становится. В чем проблема?

Оффлайн prog1c7.7

  • Модератор
  • *****
  • Сообщений: 784
  • РЕПУТАЦИЯ: 260
  • КПД: 33%
  • ну - да , ну - да...
  • Регистрация: 2010-10-20
  • Сайт: 
  • Профессия: Программист 1С
Док.Автор = Спр.ТекщийЭлемент()

А у вас что аавторы - сотрудники? по моему авторы - спр.пользователи
посмотрите описание реквизита автор

Оффлайн wmatik

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-28
  • Сайт: 
  • Профессия: Программист 1С
да, вы были правы, все получилось, спасибо


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
161 Сообщений
alex0402
76 Сообщений
oleg-x
68 Сообщений
AIFrame AIFrame
60 Сообщений
buketov.av buketov.av
44 Сообщений
wise wise
39 Сообщений
KOI8-R
35 Сообщений
Alter
29 Сообщений
Анюта17
29 Сообщений
ilyay ilyay
29 Сообщений

* Кто онлайн

  • Точка Гостей: 182
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal