Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 09:20
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Открытие формы  (Прочитано 2735 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Nemel

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-06-15
  • Сайт: 
  • Профессия: Ученик 1С
Привет всем.Есть документ,в табличной части которого есть столбец Ткань и столбец ЦветТкани. Через подбор выбираются значения в эти столбцы из справочников. Вопрос: как сделать чтоб после того как выбрал название Ткани открывался не весь справочник со списком цветов, а только группа в которой есть цвета, название ткани и название группы в справочнике Цветаткани одинаковые. Я пытался сделать так, но ничего не получается:
В модуле документа:
Процедура ПриНачалеВыбораЗначения(ид,флаг) 
Перем Спр;
Если ид="цвет" тогда
флаг=0;
ОткрытьПодбор(Справочник.цветаткани,ткань)         
КонецЕсли;
КонецПроцедуры
а в модуле справочника:
Процедура ПриОткрытии()   
    Перем Спр;
    Ткань=Форма.Ткань;
    Спр.СоздатьОбъект("Справочник.ЦветаТкани");
Если спр.НайтиПоНаименованию(Ткань)=1 Тогда
ИспользоватьРодителя(спр.ТекущийЭлемент())
КонецЕсли;
КонецПроцедуры


Оффлайн prog1c7.7

  • Модератор
  • *****
  • Сообщений: 784
  • РЕПУТАЦИЯ: 260
  • КПД: 33%
  • ну - да , ну - да...
  • Регистрация: 2010-10-20
  • Сайт: 
  • Профессия: Программист 1С
Re: Открытие формы
« Ответ #1: 15 Июн 2011, 19:42 »
это вы что то не то делаете.
вам как надо? вы хотите накидать кнопку подбор типа по фильтру? фильтр выбираете откуда - из справочника цвета ткани? потом нажимаешь как бы кнопку и появляются на выбор все элементы справочника ткани для которых  родитель (какое то та условие - вот здесь не понятно)? или как?

Оффлайн Nemel

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-06-15
  • Сайт: 
  • Профессия: Ученик 1С
Re: Открытие формы
« Ответ #2: 15 Июн 2011, 20:10 »
я хочу чтоб была кнопка (Подбор) нажал на нее в открылся справочник Ткани(без фильтра), выбрал ткань, окрывается следующий справочник ЦветаТкани(отфильтрованный) то есть  что выдавались для выбора только те цвета которые есть у этой ткани (например: есть ткань Бязь, у нее 2 цвета: белый, серый)

Оффлайн prog1c7.7

  • Модератор
  • *****
  • Сообщений: 784
  • РЕПУТАЦИЯ: 260
  • КПД: 33%
  • ну - да , ну - да...
  • Регистрация: 2010-10-20
  • Сайт: 
  • Профессия: Программист 1С
Re: Открытие формы
« Ответ #3: 15 Июн 2011, 21:22 »
а откуда база знает что у бязи только белый серый?
родитель группы - бязь называется? так?

Оффлайн Nemel

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-06-15
  • Сайт: 
  • Профессия: Ученик 1С
Re: Открытие формы
« Ответ #4: 15 Июн 2011, 22:14 »
да

Оффлайн prog1c7.7

  • Модератор
  • *****
  • Сообщений: 784
  • РЕПУТАЦИЯ: 260
  • КПД: 33%
  • ну - да , ну - да...
  • Регистрация: 2010-10-20
  • Сайт: 
  • Профессия: Программист 1С
Re: Открытие формы
« Ответ #5: 15 Июн 2011, 22:33 »
сейчас попробовал установитьотбор()
вроде нормально, но до конца не накидал, переменную с наименованием группы еще экспортнуть при открытии надо,
вобщем попробуй через установитьотбор()


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
180 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
40 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 695
  • Точка Скрытых: 0
  • Точка Пользователей: 17
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal