Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 15:51
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как правильно написать ЦИКл  (Прочитано 2122 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн help

  • **
  • Сообщений: 67
  • РЕПУТАЦИЯ: -5
  • Регистрация: 2011-01-31
  • Сайт: 
  • Профессия: Разработчик 1С
Мне надо чтобы вышло сообщение с числами 5,6,7,9 , то есть без 8-ки.
Процедура КнопкаВыполнитьНажатие(Кнопка)
   
Строка=5;
Пока Строка <10 цикл


Если строка= 8 тогда
   Продолжить;
КонецЕсли;
сообщить(строка);
Строка=строка+1;


КонецЦикла;
   
КонецПроцедуры


Оффлайн chuevsf

  • Хочу! Хочу! Хочу! Мышь на палочке!
  • Глобальный модератор
  • *****
  • Сообщений: 1376
  • РЕПУТАЦИЯ: 345
  • КПД: 25%
  • Регистрация: 2010-07-08
    • Skype: chuevsf
  • Сайт: 
  • Профессия: Программист 1С
Строка=4;
Пока Строка <10 цикл
Строка=строка+1;
Если строка= 8 тогда
   Продолжить;
КонецЕсли;
сообщить(строка);
КонецЦикла;
   
КонецПроцедуры
 
 
 
 

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
По циклу вопросов нет - в чем проблема то?

2 chuevsf,

Это цикл автора с небольшим отличием ;)
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

Как правильно настроить регламентные "Обновление индекса ППД" и "Слияние индекса ППД"

Автор bkmz_1_Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4331
Последний ответ 13 Окт 2016, 09:14
от MuI_I_Ika
Владелец задан или задан не правильно

Автор СерьезныйЧеловекРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 3310
Последний ответ 16 Сен 2010, 09:29
от ms
Как правильно "Свернуть" базу

Автор frankРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 8656
Последний ответ 12 Дек 2011, 09:52
от frank
Как правильно ввести услугу "страховка груза" (рассчитывается процентом от указанной суммы)

Автор ElenaAlmazРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 2269
Последний ответ 28 Окт 2014, 15:26
от ElenaAlmaz
Как правильно открыть вторую форму, рассчитав там данные и вбить в первую форму?

Автор s1219257Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 99
Последний ответ 27 Ноя 2017, 21:18
от s1219257

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
168 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 866
  • Точка Скрытых: 0
  • Точка Пользователей: 13
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal