Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 09:43
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: В чем ошибка  (Прочитано 1704 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн help

  • **
  • Сообщений: 67
  • РЕПУТАЦИЯ: -5
  • Регистрация: 2011-01-31
  • Сайт: 
  • Профессия: Разработчик 1С
Табл.Очистить();
Выборка = Документы[ЭлементыФормы.ОбъектПоиска.Значение].Выбрать();
Пока Выборка.Следующий() Цикл
ШКЕсть=Ложь;
Для Каждого Стр Из Выборка.ПолучитьОбъект().Табл Цикл
Если НЕ Стр.ШК="" Тогда
ШКЕсть=Истина;
КонецЕсли;
КонецЦикла;
Если ШКЕсть=Ложь Тогда
Строка = Табл.Добавить();
Строка.Документ = Выборка.Ссылка;
КонецЕсли;
КонецЦикла;

теперь пишет что {Форма.Форма.Форма(11)}: Поле объекта не обнаружено (Табл)
Для Каждого Стр Из Выборка.ПолучитьОбъект().Табл Цикл

Последний раз редактировалось: cska-fanat-kz; 14 Июн 2011, 12:48


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Re: В чем ошибка
« Ответ #1: 14 Июн 2011, 12:52 »
ну попробуйте заменить

Для Каждого Стр Из Выборка.ПолучитьОбъект().Табл Цикл

на

ДокОбъект = Выборка.ПолучитьОбъект();
Для Каждого Стр Из ДокОбъект.Табл Цикл
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Re: В чем ошибка
« Ответ #2: 15 Июн 2011, 01:05 »
Вот ----- Выборка.Ссылка.ПолучитьОбъект().Табл Цикл //К какому полю из запроса ты обращаешься то????
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Последний раз редактировалось: cska-fanat-kz; 15 Июн 2011, 06:55

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Re: В чем ошибка
« Ответ #3: 15 Июн 2011, 01:07 »
Непонятно только зачем ты это делаешь?!!!!
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 

При открытии обр-ки в "Предприятии" есть ошибка, а в "Отладке" нет

Автор proofetРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4530
Последний ответ 21 Сен 2011, 17:35
от proofet
ошибка "Невозможно обработать параметр "ПрофильПолномочийПользователя""

Автор lindeluРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 6088
Последний ответ 06 Июн 2012, 09:15
от lindelu
Синтаксическая ошибка "В" Номенклатура.Ссылка = <<?>> В ИЕРАРХИИ(&Ссылка)

Автор maskitoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4199
Последний ответ 28 Апр 2014, 15:53
от maskito
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8504
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
Ошибка при загрузке данных через (Обработка "Выгрузка и загрузка данных XML")

Автор Сергей_87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 8564
Последний ответ 26 Апр 2012, 23:08
от Dethmontt

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
180 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
40 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 762
  • Точка Скрытых: 0
  • Точка Пользователей: 15
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal