Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 03:45
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Передача строки из формы выбора в форму элемента справочника.  (Прочитано 6444 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн |R|U|D|E|N

  • ***
  • Сообщений: 217
  • РЕПУТАЦИЯ: 3
  • КПД: 1%
  • Регистрация: 2011-01-09
  • Компания: Virtual-Kernel | KVM | Xen
  • Профессия: Разработчик 1С
Добрый день.

В обычном приложении делал просто, а вот в управляемом не получется..

У меня есть форма выбора справочника серийных номеров. В этой форме есть поле ввода по которому осуществляется отбор. В случае если отбор не дал результата(нет такого серийника) то рядом с этим полем я разместил кнопку создать по нажатию на которую у меня открывается формаЭлемента и я очень хочу чтоб тот серийник указанный в поле отбора автоматически попадал в соответствующее поле формы Элемента. Тойсть чтоб не наберать/копировать снова серийник при необходимости его создания.

Подскажите как это можно сделать?


С уважением, Александр.


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
А как вы открываете форму нового элемента?
Запостите код...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Шурыгин Иван Сергеевич

  • забей на все....
  • ****
  • Сообщений: 330
  • РЕПУТАЦИЯ: 82
  • КПД: 25%
  • забей на все!
  • Регистрация: 2011-05-23
  • Сайт: 
  • Профессия: Программист 8.1
используйте что то типо такого кода

Процедура КнопкаДобавитьНовыйНажатие(Кнопка)
Спр = Справочники.СерийныеНомера.СоздатьЭлемент();
Спр.СерийныйНомер = СерийныйНомер;
Спр.ПолучитьФорму().Открыть();
КонецПроцедуры
===================================
жизнь надо прожить так, чтоб вверху посмотрели.
и сказали "А ну ка повтори"
===================================

Оффлайн |R|U|D|E|N

  • ***
  • Сообщений: 217
  • РЕПУТАЦИЯ: 3
  • КПД: 1%
  • Регистрация: 2011-01-09
  • Компания: Virtual-Kernel | KVM | Xen
  • Профессия: Разработчик 1С
Вот как у меня сейчас

&НаКлиенте
//В этой процедуре выполняется отбор
Процедура НайтиСерийник(Команда)
 
//отбор по одному полю
Отбор = Список.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
Отбор.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
Отбор.ПравоеЗначение = ИскомоеЗначение;
Отбор.Использование = Истина;
Отбор.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("Наименование");

КонецПроцедуры

&НаКлиенте
Процедура Создать(Команда)


ФормаЭлемента = ПолучитьФорму("Справочник.СерийныеНомера.Форма.ФормаЭлемента");
ФормаЭлемента.Открыть();

КонецПроцедуры

При этом ФормаЭлемента открывается но как автоматически заполнить поле Наименование введеным ранне сирийником?


Попробовал выше преведенный код в серверной процедуре

&НаСервере
Процедура СоздатьНовый(Серийник)

Спр = Справочники.СерийныеНомера.СоздатьЭлемент();
Спр.Наименование = Серийник;
Спр.ПолучитьФорму().Открыть();


КонецПроцедуры


Вываливается вот это

{Справочник.СерийныеНомера.Форма.ФормаВыбора_Управляемая.Форма(40)}: Ошибка при вызове метода контекста (ПолучитьФорму): Интерактивные операции недоступны
   Спр.ПолучитьФорму().Открыть();
по причине:
Интерактивные операции недоступны


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Ну правильно.
На Сервере нельзя форму показывать...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн |R|U|D|E|N

  • ***
  • Сообщений: 217
  • РЕПУТАЦИЯ: 3
  • КПД: 1%
  • Регистрация: 2011-01-09
  • Компания: Virtual-Kernel | KVM | Xen
  • Профессия: Разработчик 1С
Я пробовал

 Спр = Справочники.СерийныеНомера.СоздатьЭлемент();
 Спр.Наименование = Серийник;

Разместить на сервере

А вот это

Спр.ПолучитьФорму().Открыть();

уже на клиенте

Но у меня не чего не вышло..


Если не сложно, покажите  плиз как это в коде должно выглядеть? я уже все перепробовал, не хочет у меня работать...

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Все таки 8.2 вносит определенный сумбур в головы...

Получилось например так:
&НаКлиенте
Процедура ПриОткрытии(Отказ)
     ФормаНовойНоменклатуры = ПолучитьФорму("Справочник.Номенклатура.ФормаОбъекта");
     ФормаНовойНоменклатуры.Объект.Наименование = "Значение";
     ФормаНовойНоменклатуры.Открыть();
КонецПроцедуры
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн |R|U|D|E|N

  • ***
  • Сообщений: 217
  • РЕПУТАЦИЯ: 3
  • КПД: 1%
  • Регистрация: 2011-01-09
  • Компания: Virtual-Kernel | KVM | Xen
  • Профессия: Разработчик 1С
Ахренеть!

Спасибо всем а особенно cska-fanat-kz! Работает именно так как надо!

P.S Я бы в жизни не поверил что такой код сработает:
 
ФормаНовойНоменклатуры.Объект.Наименование = "Значение";

Оффлайн |R|U|D|E|N

  • ***
  • Сообщений: 217
  • РЕПУТАЦИЯ: 3
  • КПД: 1%
  • Регистрация: 2011-01-09
  • Компания: Virtual-Kernel | KVM | Xen
  • Профессия: Разработчик 1С
Если честно, я уже около 4-х месяцев пишу только на 8.2 управляемое приложение и у меня уже в голове не укладывается как можно например прямо из формы документа обращаться к чему угодно без разделения кода на серверные и клиентские процедуры. правда, вот такие моменты как в этой теме жутко бесят))

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Код не претендует на правильность между прочим! )
Иногда получить результат мало...

1. Форма открывается без признака модифицированности... То есть при закрытии не спрашивает о сохранении. Лень было искать что нибудь вроде
ФормаНовойНоменклатуры.Модифицированность = ИСТИНА; ;))

2. "ФормаНовойНоменклатуры.Объект.Наименование = "Значение";" нашел методом тыка.
Возможно создатель 8.2 перевернулся... в кровати (дай Бог ему здоровья!) ))


P.S. Со штукой меня! )))
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

Как вызвать "Анализ субконто" из справочника "Контрагенты"

Автор EnigManРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 6495
Последний ответ 06 Фев 2012, 10:46
от cska-fanat-kz
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4199
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 624
Последний ответ 10 Май 2017, 20:44
от ilnur75
Не работает метод Сдвинуть() по отношению к программно добавляемой колонке1С:Предприятие 8.3 (8.3.10.2561) Управление производственным предприятием, редакция 1.4 Приветствую, я добавляю программно свою колонку в методе ПриОткрытии() модуля формы, вот так

Автор InsiderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 285
Последний ответ 21 Сен 2017, 10:33
от Insider
Как сделать, чтобы поле в документе имело тип "ссылка на поле справочника"?

Автор друганРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2032
Последний ответ 05 Мар 2017, 14:36
от Igor100500

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
178 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
29 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 184
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal