Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 00:45
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Заполения табличного поля и поля (8.2 управляемая)  (Прочитано 1889 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ММиха

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-06-09
  • Сайт: 
  • Профессия: Ученик 1С
Прошу в помощи с процедурой ..  :dfbsdfbsdf: в курсовой...
Помогите пожалуйста с процедурой
Документ ПрохожденияКурсаОбучения, в нем при выборе ЗавякиНаОбучения (документ) в документе ПрохожденияКурсаОбучения должно заполнится поле Курс Обучения и В табличном поле сторутдник
&НаКлиенте
Процедура ЗаявкаПриИзменении(Элемент)
ссылка = Объект.Заявка;   
ЗАпросДАнных(ссылка);   
   
   
   
   
КонецПроцедуры



&НаСервере
Функция ЗАпросДАнных(Ссылка)
      //{{КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
   // Данный фрагмент построен конструктором.
   // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
    Массив = Новый Массив;
      //{{КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
   // Данный фрагмент построен конструктором.
   // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
    Запрос = Новый Запрос;
   Запрос.Текст =
      "ВЫБРАТЬ
      |   ПотребностиВОбучении.Регистратор,
      |   ПотребностиВОбучении.КурсОбучения,
      |   ПотребностиВОбучении.Сотрудник,
      |   ПотребностиВОбучении.ДатаЗаявки,
      |   ПотребностиВОбучении.Отметка
      |ИЗ
      |   РегистрНакопления.ПотребностиВОбучении КАК ПотребностиВОбучении
      |ГДЕ
      |   ПотребностиВОбучении.Регистратор = &Ссылка";
     
    Запрос.УстановитьПараметр("Ссылка",Ссылка);

   Результат = Запрос.Выполнить().Выгрузить();

   ВыборкаДетальныеЗаписи = Результат;

ДЛя каждого Строка Из ВыборкаДетальныеЗаписи Цикл
      Массив.Добавить(Строка);
   КонецЦикла;

   
   Возврат
   Массив;
   
КонецФункции;

ссылка на ИБ
http://file.qip.ru/file/sJRYHQ5L/InfoBase.htmlЗ


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн ММиха

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-06-09
  • Сайт: 
  • Профессия: Ученик 1С
процедура не работает

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
ЗапросДанных() - у вас функция, возвращает массив...
А вызываете ее как процедуру...
Наверное должно быть...
Массив = ЗапросДанных(ссылка);

и так далее...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

Загрузка из "нестандартного" табличного документа (exel) в справочник

Автор uchenichokРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1002
Последний ответ 03 Июн 2016, 07:15
от cska-fanat-kz
Форматирование ячейки типа "Шаблон" в макете табличного документа

Автор KatishРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 19435
Последний ответ 11 Апр 2012, 11:13
от cska-fanat-kz
Редактирование одной ячейки табличного документа в отчете, созданном вручную

Автор lighthead9288Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 8263
Последний ответ 05 Фев 2014, 23:41
от lighthead9288
Перестала работать обработка - загрузка данных табличного документа

Автор LusiyaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1970
Последний ответ 30 Дек 2014, 11:39
от Luzer1C
Ориентация страницы табличного документа при сохранении в формат docx

Автор v.khРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2753
Последний ответ 28 Апр 2015, 12:57
от vitasw

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
133 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
61 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 199
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal