Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
22 Май 2018, 01:44
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Заполения табличного поля и поля (8.2 управляемая)  (Прочитано 1976 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ММиха

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-06-09
  • Сайт: 
  • Профессия: Ученик 1С
Прошу в помощи с процедурой ..  :dfbsdfbsdf: в курсовой...
Помогите пожалуйста с процедурой
Документ ПрохожденияКурсаОбучения, в нем при выборе ЗавякиНаОбучения (документ) в документе ПрохожденияКурсаОбучения должно заполнится поле Курс Обучения и В табличном поле сторутдник
&НаКлиенте
Процедура ЗаявкаПриИзменении(Элемент)
ссылка = Объект.Заявка;   
ЗАпросДАнных(ссылка);   
   
   
   
   
КонецПроцедуры



&НаСервере
Функция ЗАпросДАнных(Ссылка)
      //{{КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
   // Данный фрагмент построен конструктором.
   // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
    Массив = Новый Массив;
      //{{КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
   // Данный фрагмент построен конструктором.
   // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
    Запрос = Новый Запрос;
   Запрос.Текст =
      "ВЫБРАТЬ
      |   ПотребностиВОбучении.Регистратор,
      |   ПотребностиВОбучении.КурсОбучения,
      |   ПотребностиВОбучении.Сотрудник,
      |   ПотребностиВОбучении.ДатаЗаявки,
      |   ПотребностиВОбучении.Отметка
      |ИЗ
      |   РегистрНакопления.ПотребностиВОбучении КАК ПотребностиВОбучении
      |ГДЕ
      |   ПотребностиВОбучении.Регистратор = &Ссылка";
     
    Запрос.УстановитьПараметр("Ссылка",Ссылка);

   Результат = Запрос.Выполнить().Выгрузить();

   ВыборкаДетальныеЗаписи = Результат;

ДЛя каждого Строка Из ВыборкаДетальныеЗаписи Цикл
      Массив.Добавить(Строка);
   КонецЦикла;

   
   Возврат
   Массив;
   
КонецФункции;

ссылка на ИБ
http://file.qip.ru/file/sJRYHQ5L/InfoBase.htmlЗ


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн ММиха

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-06-09
  • Сайт: 
  • Профессия: Ученик 1С
процедура не работает

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
ЗапросДанных() - у вас функция, возвращает массив...
А вызываете ее как процедуру...
Наверное должно быть...
Массив = ЗапросДанных(ссылка);

и так далее...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

Загрузка из "нестандартного" табличного документа (exel) в справочник

Автор uchenichokРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1287
Последний ответ 03 Июн 2016, 07:15
от cska-fanat-kz
Форматирование ячейки типа "Шаблон" в макете табличного документа

Автор KatishРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 20673
Последний ответ 11 Апр 2012, 11:13
от cska-fanat-kz
Редактирование одной ячейки табличного документа в отчете, созданном вручную

Автор lighthead9288Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 9155
Последний ответ 05 Фев 2014, 23:41
от lighthead9288
Как подсчитать количество строк табличного документа которые выведутся на 1 странице

Автор Серж МаслаковРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 529
Последний ответ 25 Дек 2017, 04:04
от AIFrame
Перестала работать обработка - загрузка данных табличного документа

Автор LusiyaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 2282
Последний ответ 30 Дек 2014, 11:39
от Luzer1C

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
146 Сообщений
oleg-x
66 Сообщений
alex0402
63 Сообщений
AIFrame AIFrame
52 Сообщений
wise wise
37 Сообщений
KOI8-R
34 Сообщений
buketov.av buketov.av
34 Сообщений
Alter
25 Сообщений
trialex3
20 Сообщений
BuhRust
20 Сообщений

* Кто онлайн

  • Точка Гостей: 160
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal