Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 08:07
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Рассчёт скидки покупателю, прошу помощи.  (Прочитано 1581 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн SoulPower

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-30
  • Сайт: 
  • Профессия: Ученик 1С
Задача: Добавить автоматически расчёт скидки покупателю при оформлении расходной накладной, Размер скидки зависит от суммы уже произведённых закупок в предыдущем месяце.

Скидки я храню в справочнике, сделки покупателей в регистре Продажи. Из клиентского приложения при изминении клиента вызываю функцию, которая выполняется на сервере, вот листинг:

Функция ВычислениеСкидки(Клиент) Экспорт
   ДатаНачала = НачалоМесяца(ДобавитьМесяц(ТекущаяДата(), -1));
   ДатаОкончания = КонецМесяца(ДобавитьМесяц(ТекущаяДата(), -1));
   ОборотКлиента = РегистрыНакопления.Продажи.Обороты(ДатаНачала,ДатаОкончания,,Клиент,"Выручка");
    Запрос = Новый Запрос;
   Запрос.Текст ="ВЫБРАТЬ
                 |   Скидки.ОбъемЗакупки КАК ОбъемЗакупки,
                 |   Скидки.ПроцентСкидки
                 |ИЗ
                 |   Справочник.Скидки КАК Скидки
                 |
                 |УПОРЯДОЧИТЬ ПО
                 |   ОбъемЗакупки УБЫВ";
   Результат = Запрос.Выполнить();
   ТЗ = Результат.Выгрузить();
   ВыборкаДетальныеЗаписи = Результат.Выбрать();
   Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
      Если ОборотКлиента >= ВыборкаДетальныеЗаписи.ОбъемЗакупки тогда
         Возврат ВыборкаДетальныеЗаписи.ПроцентСкидки;
      КонецЕсли;
   КонецЦикла;   
КонецФункции

Проблема вот в чём:
Метод Обороты() ругается на параметр Клиент, а я ему вроде передаю строку как и надо.

Да и вообще нихрена не работает, помогите плиз)

   


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
135 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
63 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 375
  • Точка Скрытых: 0
  • Точка Пользователей: 9
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal