Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 03:17
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Ошибка в коде Печати  (Прочитано 1533 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн asmut

  • *
  • Сообщений: 29
  • РЕПУТАЦИЯ: -6
  • Чем лучше груди, тем хуже запоминается лицо
  • Регистрация: 2011-06-02
  • Сайт: 
  • Профессия: Ученик 1С
День добрый господа, вот изучаю 8.2 (8.2.13.205), настроил под Обычное приложение, Отладка через Толстый клиент под Админом (роли и права полные), все шло хорошо до вот этого полотна.

Ошибка на строке:  Выборка = Справочники.Курсы.Выбрать (,,СО);

Все работает, а именно до момента нажатия на Печать.

Буду признателен за помощь.



Процедура Печать(Элемент)

 ТабДок = Новый ТабличныйДокумент;
 Макет = Справочники.Курсы.ПолучитьМакет("Печать");
 // Заголовок
 Область = Макет.ПолучитьОбласть("Заголовок");
 ТабДок.Вывести(Область);
 // Шапка
 Область = Макет.ПолучитьОбласть("Шапка");
 ТабДок.Вывести(Область);
 //тело
 Если (ЭлементыФормы.КороткиеКурсы.Значение = Истина) Тогда
 СО = Новый Структура;
 СО.Вставить("Продолжительность",2);
 Выборка = Справочники.Курсы.Выбрать (,,СО);
 Иначе
 Выборка = Справочники.Курсы.Выбрать();
 КонецЕсли;
 Пока Выборка.Следующий() = Истина Цикл
 Объект = Выборка.ПолучитьОбъект();
 Область = Макет.ПолучитьОбласть("Элемент");
 Область.Параметры.Наименование = Объект.Наименование;
 Область.Параметры.Начало = Объект.Начало;
 Область.Параметры.Продолжительность = Объект.Продолжительность;
 Область.Параметры.Преподаватель = Объект.Преподаватель;
 ТабДок.Вывести(Область);
 КонецЦикла;
 ТабДок.ОтображатьСетку = Ложь;
 ТабДок.Защита = Ложь;
 ТабДок.ТолькоПросмотр = Ложь;
 ТабДок.ОтображатьЗаголовки = Ложь;
 ТабДок.Показать();

КонецПроцедуры


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
"В качестве полей для отбора могут задаваться только поля "Код", "Наименование" и реквизиты справочника, для которых в конфигураторе признак индексирования установлен в значение "Индексировать" или в значение "Индексировать с доп. упорядоч.". "

Не ваш случай?
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн asmut

  • *
  • Сообщений: 29
  • РЕПУТАЦИЯ: -6
  • Чем лучше груди, тем хуже запоминается лицо
  • Регистрация: 2011-06-02
  • Сайт: 
  • Профессия: Ученик 1С
"В качестве полей для отбора могут задаваться только поля "Код", "Наименование" и реквизиты справочника, для которых в конфигураторе признак индексирования установлен в значение "Индексировать" или в значение "Индексировать с доп. упорядоч.". "

Не ваш случай?

Случай мой)) Вчера разобрался сам, но тебе спасибо.


Теги:
 

При открытии обр-ки в "Предприятии" есть ошибка, а в "Отладке" нет

Автор proofetРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4530
Последний ответ 21 Сен 2011, 17:35
от proofet
ошибка "Невозможно обработать параметр "ПрофильПолномочийПользователя""

Автор lindeluРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 6086
Последний ответ 06 Июн 2012, 09:15
от lindelu
Синтаксическая ошибка "В" Номенклатура.Ссылка = <<?>> В ИЕРАРХИИ(&Ссылка)

Автор maskitoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4199
Последний ответ 28 Апр 2014, 15:53
от maskito
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8502
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
Ошибка при загрузке данных через (Обработка "Выгрузка и загрузка данных XML")

Автор Сергей_87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 8563
Последний ответ 26 Апр 2012, 23:08
от Dethmontt

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
178 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
29 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 184
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal