Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 00:05
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Обновление данных в табличном поле обработки  (Прочитано 1993 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн daringer

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-07-28
  • Сайт: 
Здравствуйте! Есть обработка в которой есть 2 табличные части: контрагенты и комплекты. При нажатии на контрагента в комплектах отбираются данные по этому контрагенту из регистра сведений. Как сделать так чтоб после создание движений документом  в регистре сведений, в табличной части обработки комплекты автоматически обновились данные для контрагента???


Оффлайн Шурыгин Иван Сергеевич

  • забей на все....
  • ****
  • Сообщений: 330
  • РЕПУТАЦИЯ: 82
  • КПД: 25%
  • забей на все!
  • Регистрация: 2011-05-23
  • Сайт: 
  • Профессия: Программист 8.1
есть 2 события... приАктивизацииСтроки и ПриПолученииДанных...
например когда пользователь кликает на строчку с контрагентом, то у него вызывается
в процедуре вызывается процедура

 
Процедура КонтрагентыПриАктивизацииСтроки(Элемент,СтандартнаяОбработка)
    ОбновитьДанныеПоКомлекту();
КонецПроцедуры

Процедура ОбновитьДанныеПоКомлекту()
Контрагент = ЭлементыФормы.Контрагенты.ТекущаяСтрока.Контрагент;
//Далее работа по обновлению информации по контрагенту
КонецПроцедуры

Процедура КонтрагентыПриПолученииДанных()
   ОбновитьДанныеПоКомлекту();
КонецПроцедуры


попробуйте что то типо такого кода... (если я конечно правильно понял задачу)
===================================
жизнь надо прожить так, чтоб вверху посмотрели.
и сказали "А ну ка повтори"
===================================

Оффлайн daringer

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-07-28
  • Сайт: 
Спасибо. Я сделал с помощью обработки оповещения!)


Теги:
 

Перенос данных из 1с 82 БП (базовая) в 1с 82 БГУ (базовая)

Автор Владимир87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7443
Последний ответ 06 Дек 2014, 17:40
от дфтын
Поиск по бае данных,(полнотекстовый поиск)

Автор kot_ooРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3887
Последний ответ 19 Май 2014, 15:40
от kot_oo
Поле не найдено"ЗаказПокупателя.Услуги.Ссылка"<<?>>ЗаказПокупателя.Услуги.Ссылка

Автор romanprogrammistРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 6940
Последний ответ 05 Дек 2013, 00:01
от romanprogrammist
Как исправить при обновлении ИБ: Ошибка в запросе набора данных по причине: {(58, 2)}: Несовместимые типы "ВЫБОР" <<?>>ВЫБОР

Автор dollРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2117
Последний ответ 01 Янв 2017, 20:27
от Геннадий ОбьГЭС
"Задваивание" данных в отчете

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 13
Просмотров: 7349
Последний ответ 15 Окт 2015, 11:21
от Mari_beginner

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
170 Сообщений
ilyay ilyay
69 Сообщений
oleg-x
48 Сообщений
alex0402
44 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 205
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal