Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 17:06
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: помогите понять,что с отчётом  (Прочитано 4493 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Изабелла Герман

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-30
  • Сайт: 
  • Профессия: Ученик 1С
Доброго времени суток.
Вопрос такой:при формировании отчёта остаётся пустой колонка КоличествоРасход.Почему?


Оффлайн chuevsf

  • Хочу! Хочу! Хочу! Мышь на палочке!
  • Глобальный модератор
  • *****
  • Сообщений: 1376
  • РЕПУТАЦИЯ: 345
  • КПД: 25%
  • Регистрация: 2010-07-08
    • Skype: chuevsf
  • Сайт: 
  • Профессия: Программист 1С
Какая конфигурация?
Какой отчет?
Подробнее можно написать?

P.S. Мы же тут не телепаты сидим.

Оффлайн Изабелла Герман

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-30
  • Сайт: 
  • Профессия: Ученик 1С
Я только пытаюсь научиться работать с 1с,пользуюсь руководством.На компе стоит 1с-предприятие 8. У меня предприятие оказывает услуги по ремонту техники.Если оказана услуга,то должны списаться использованные материалы.На сколько я понимаю,если сформировать отчёт по остаткам материалов,там в колонке КоличествоРасход должно отобразиться,сколько материалов израсходовано,но она пуста,хотя я провела документ об оказании услуги.

Оффлайн chuevsf

  • Хочу! Хочу! Хочу! Мышь на палочке!
  • Глобальный модератор
  • *****
  • Сообщений: 1376
  • РЕПУТАЦИЯ: 345
  • КПД: 25%
  • Регистрация: 2010-07-08
    • Skype: chuevsf
  • Сайт: 
  • Профессия: Программист 1С
А может тогда проще нанять человек за деньги, чтобы на месте объяснил, показал и рассказал что и как надо делать?

А то "вынос мозга" здесь нам точно не нужен!
Как Вам мы можем помочь, если даже Вы не можете сказать в какой базе Вы работаете и каким отчетом пользуетесь.

Оффлайн Изабелла Герман

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-30
  • Сайт: 
  • Профессия: Ученик 1С
Да,я неправильно задаю вопрос,потому как не знаю многого.Но ,в принципе,зачем форум,если нельзя задавать вопросы и просить помощи?
А денег у меня нет.

Оффлайн Шурыгин Иван Сергеевич

  • забей на все....
  • ****
  • Сообщений: 330
  • РЕПУТАЦИЯ: 82
  • КПД: 25%
  • забей на все!
  • Регистрация: 2011-05-23
  • Сайт: 
  • Профессия: Программист 8.1
когда входите в программу нажмите справка - о программе так будет информация или скиньте скрин шот.... второе назовите название отчета или скиньте скринош отчета
===================================
жизнь надо прожить так, чтоб вверху посмотрели.
и сказали "А ну ка повтори"
===================================

Оффлайн MaryaAlbertovna

  • **
  • Сообщений: 87
  • РЕПУТАЦИЯ: 20
  • КПД: 23%
  • Регистрация: 2011-04-01
  • Сайт: 
  • Профессия: Бухгалтер
Да,я неправильно задаю вопрос,потому как не знаю многого.Но ,в принципе,зачем форум,если нельзя задавать вопросы и просить помощи?

Нажмите на информацию о программе - на панели круг с буквой или или вопросик

полезная ссылка itforyou.ru

Оффлайн chuevsf

  • Хочу! Хочу! Хочу! Мышь на палочке!
  • Глобальный модератор
  • *****
  • Сообщений: 1376
  • РЕПУТАЦИЯ: 345
  • КПД: 25%
  • Регистрация: 2010-07-08
    • Skype: chuevsf
  • Сайт: 
  • Профессия: Программист 1С
Да,я неправильно задаю вопрос,потому как не знаю многого.Но ,в принципе,зачем форум,если нельзя задавать вопросы и просить помощи?
А денег у меня нет.
Я конечно могу показаться грубым, но! Выше указанная фраза меня просто убила!
Как можно на неверно заданный вопрос, получить верный ответ?
На форумах, чтобы Вам помогли, надо задать четкий вопрос. Тогда, я уверен, можно будет получить исчерпывающий правильный ответ.
Иначе - никак!

P.S. А по поводу денег, то я счастлив, что Вы живете уже при коммунизме! Бизнесвумен, блин!
Что-то я сегодня вообще нетерпимый какой-то. )))

Оффлайн Изабелла Герман

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-30
  • Сайт: 
  • Профессия: Ученик 1С
Спасибо,но я сама разобралась.
дело было в процедуре ОбработкаПроведения,поправила движения,всё записалось.
Но возникла новая проблема:
создала оборотный регистр накопления Продажи.Чтобы Документ ОказаниеУслуги создавал движения по регистру Продажи,изменила процедуру ОбработкаПроведения.Но при перепроведении документа ОказаниеУслуги,движения по регистру нет.Я так понимаю,что проблема опять в процедуре,но не могу найти ошибку.
Вот процедура ОбработкаПроведения:(У меня 1С:Предприятие 8.1 (8.1.15.14), я пытаюсь разобраться с типовыми задачами)

Процедура ОбработкаПроведения(Отказ,Режим)
   Для Каждого ТекСтрокаПереченьНоменклатуры Из ПереченьНоменклатуры Цикл
      Если ТекСтрокаПереченьНоменклатуры.Номенклатура.ВидНоменклатуры<>
         Перечисления.ВидыНоменклатуры.Материал Тогда Продолжить;
      КонецЕсли;
Движение=Движения.ОстаткиМатериалов.Добавить();
Движение.ВидДвижения=ВидДвиженияНакопления.Расход;
Движение.Период=Дата;
Движение.Материал=ТекСтрокаПереченьНоменклатуры.Номенклатура;
Движение.Склад=Склад;
Движение.Количество=ТекСтрокаПереченьНоменклатуры.Количество;

Движение=Движения.СтоимостьМатериалов.Добавить();
Движение.ВидДвижения=ВидДвиженияНакопления.Расход;
Движение.Период=Дата;
Движение.Материал=ТекСтрокаПереченьНоменклатуры.Номенклатура;
Движение.Стоимость=ТекСтрокаПереченьНоменклатуры.Стоимость*
   ТекСтрокаПереченьНоменклатуры.Количество;
КонецЦикла;
Для Каждого ТекСтрокаПереченьНоменклатуры Из ПереченьНоменклатуры Цикл
// вот для регистра Продажи
Движение=Движения.Продажи.Добавить();
Движение.Период=Дата;
Движение.Номенклатура=ТекСтрокаПереченьНоменклатуры.Номенклатура;
Движение.клиент=Клиент;
Движение.Мастер=Мастер;
Движение.Количество=ТекСтрокаПереченьНоменклатуры.Количество;
Движение.Выручка=ТекСтрокаПереченьНоменклатуры.Сумма;
Движение.Стоимость=ТекСтрокаПереченьНоменклатуры.Стоимость*
      ТекСтрокаПереченьНоменклатуры.Количество;

КонецЦикла;                                     
Движения.ОстаткиМатериалов.Записать();
Движения.СтоимостьМатериалов.Записать();
Движения.Продажи.Записать();
КонецПроцедуры

Оффлайн chuevsf

  • Хочу! Хочу! Хочу! Мышь на палочке!
  • Глобальный модератор
  • *****
  • Сообщений: 1376
  • РЕПУТАЦИЯ: 345
  • КПД: 25%
  • Регистрация: 2010-07-08
    • Skype: chuevsf
  • Сайт: 
  • Профессия: Программист 1С
Мда.... Посмотрим через пару месяцев, что у вас получиться дальше.....

P.S. Я уже запасаюсь попкорном и кока-колой.


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4303
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5560
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5900
Последний ответ 28 Мар 2012, 13:02
от chum710
помогите разбораться в обработке документов "ЗаказТоваров"

Автор proofetРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 10
Просмотров: 7979
Последний ответ 18 Май 2011, 09:50
от cska-fanat-kz
Помогите с созданием обработки "Работа со справочниками"

Автор ИдзумиРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3478
Последний ответ 06 Сен 2012, 15:45
от Идзуми

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
59 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 314
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal