Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 02:49
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Сообщить()  (Прочитано 6492 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Maxim

  • ***
  • Сообщений: 248
  • РЕПУТАЦИЯ: 10
  • КПД: 4%
  • Регистрация: 2010-11-09
  • Сайт: 
Доброго времени суток! :btbzdb: Как выводить сообщение при обходе цикла? Сообщает когда полностью завершает цикл, что делать? :dfbbdrfb:


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Re: Сообщить()
« Ответ #1: 27 Май 2011, 09:33 »
Не понял....
Нельзя метод Сообщить() вставить внутрь цикла?

Пока Выборка.Следующий() Цикл
      Сообщить(Выборка.Ссылка);
КонецЦикла;
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн chuevsf

  • Хочу! Хочу! Хочу! Мышь на палочке!
  • Глобальный модератор
  • *****
  • Сообщений: 1376
  • РЕПУТАЦИЯ: 345
  • КПД: 25%
  • Регистрация: 2010-07-08
    • Skype: chuevsf
  • Сайт: 
  • Профессия: Программист 1С
Re: Сообщить()
« Ответ #2: 27 Май 2011, 09:33 »
Для i=1 По 10 Цикл
Сообщить("номер продохода цикла: " + i);
КонецЦикла;

Оффлайн chuevsf

  • Хочу! Хочу! Хочу! Мышь на палочке!
  • Глобальный модератор
  • *****
  • Сообщений: 1376
  • РЕПУТАЦИЯ: 345
  • КПД: 25%
  • Регистрация: 2010-07-08
    • Skype: chuevsf
  • Сайт: 
  • Профессия: Программист 1С
Re: Сообщить()
« Ответ #3: 27 Май 2011, 09:35 »
Не понял....

Похоже, что мы тут еще много кое-чего не понимаем! )))

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
Re: Сообщить()
« Ответ #4: 27 Май 2011, 09:38 »
Не понял....

Похоже, что мы тут еще много кое-чего не понимаем! )))

Видимо автор говорит о том, что система "подвисает" до окончания выполнения цикла....

Оффлайн chuevsf

  • Хочу! Хочу! Хочу! Мышь на палочке!
  • Глобальный модератор
  • *****
  • Сообщений: 1376
  • РЕПУТАЦИЯ: 345
  • КПД: 25%
  • Регистрация: 2010-07-08
    • Skype: chuevsf
  • Сайт: 
  • Профессия: Программист 1С
Re: Сообщить()
« Ответ #5: 27 Май 2011, 09:42 »
Не понял....
Похоже, что мы тут еще много кое-чего не понимаем! )))

Видимо автор говорит о том, что система "подвисает" до окончания выполнения цикла....

Сижу я медитирую,
Сижу телепатирую.
Я буду предсказателем,
Причем за всех, за всякого.

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
Re: Сообщить()
« Ответ #6: 27 Май 2011, 09:58 »
Не понял....
Похоже, что мы тут еще много кое-чего не понимаем! )))

Видимо автор говорит о том, что система "подвисает" до окончания выполнения цикла....

Сижу я медитирую,
Сижу телепатирую.
Я буду предсказателем,
Причем за всех, за всякого.
Это ты к чему?

Оффлайн chuevsf

  • Хочу! Хочу! Хочу! Мышь на палочке!
  • Глобальный модератор
  • *****
  • Сообщений: 1376
  • РЕПУТАЦИЯ: 345
  • КПД: 25%
  • Регистрация: 2010-07-08
    • Skype: chuevsf
  • Сайт: 
  • Профессия: Программист 1С
Re: Сообщить()
« Ответ #7: 27 Май 2011, 10:00 »
К тому, что частенько авторы задают вопросы таким способом, что приходится за них не только думать об ответе, но и еще, за них же, правильно формулировать вопросы.
Вот и жалею, что я не телепат.

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
Re: Сообщить()
« Ответ #8: 27 Май 2011, 10:03 »
К тому, что частенько авторы задают вопросы таким способом, что приходится за них не только думать об ответе, но и еще, за них же, правильно формулировать вопросы.
Вот и жалею, что я не телепат.

Вот это верно. Тем более что у автора и репутация выше нуля и количество сообщений приличное...

Оффлайн Maxim

  • ***
  • Сообщений: 248
  • РЕПУТАЦИЯ: 10
  • КПД: 4%
  • Регистрация: 2010-11-09
  • Сайт: 
Re: Сообщить()
« Ответ #9: 27 Май 2011, 10:10 »
Это точно, короче, ещё раз сформулирую вопрос, мне нужно чтобы сообщение выводилось не после завершения цикла, а в момент их выполнения, пример такой:
Для i=1 По 10 Цикл
     Сообщить("номер продохода цикла: " + i);
КонецЦикла;


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
46 Сообщений
oleg-x
44 Сообщений
andron81_81
44 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
BuhRust
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 133
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal