Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 14:18
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Сравнение даты в 1С  (Прочитано 12333 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн kadzik

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-27
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте.
е пойму, в чем ошибка в коде процедуры 1С 8.2.
Процедура должна работать таким образом - при вводе данных в поле ДатаДоставки производится проверка на ее соответствие с текущей датой. Если ДатаДоставки меньше - выводится сообщение и в поле подставляется текущая дата (или запрещается проведение документа).

Мой код:

Перем ТекущаяДата;
&НаКлиенте
Процедура ДатаПриИзменении(Элемент)
Дата1=Объект.ДатаДоставки;
Дата2= ТекущаяДата();
Если Дата1<Дата2 Тогда
ПоказатьОповещениеПользователя ("Нельзя указать прошедшую дату");
Объект.ДатаДоставки = ТекущаяДата();
Возврат;
КонецЕсли;

КонецПроцедуры

В результате документ просто записывается и проверки не происходит.
Как правильно написать?


Оффлайн Nail2010

  • ****
  • Сообщений: 325
  • РЕПУТАЦИЯ: 18
  • КПД: 6%
  • Регистрация: 2010-10-27
  • Сайт: 
Попробуй код сделать проще:

Процедура ДатаПриИзменении(Элемент)
Если Объект.Дата<ТекущаяДата() Тогда
Предупреждение ("Нельзя указать прошедшую дату");
Объект.Дата = ТекущаяДата();
КонецЕсли;
КонецПроцедуры


И на будущее - ВОЗВРАТ в процедуре не имеет смысла - он только для функции

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Ну почему же, Возврат и для процедуры имеет смысл.
Он прекращает ее выполнение, и возвращает выполнение в место, откуда была вызвана эта процедура.
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Как вариант...

Реквизит называется ДатаДоставки
а обработчик события - ДатаПриИзменении()...

Если создавать автоматом, то получилось бы
ДатаДоставкиПриИзменении()

Процедуру сами писали?
В качестве обработчика подключили?
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Slin

  • Глобальный модератор
  • *****
  • Сообщений: 780
  • РЕПУТАЦИЯ: 247
  • КПД: 32%
  • Game over...
  • Регистрация: 2010-10-13
  • Сайт: 
  • Профессия: Программист 1С
Событие ПриИзменении срабатывает только в момент передачи фокус из соответсвующего элемента управления (перход на другой и т.п.). При проведении или  записи данное событие не возникает и, соответственно, не обрабатывается.
Для проверки в момент записи, обрабатывайте соответсвующее событие.
skype: slin-dev

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
2 Slin,
у него сказано так:
Цитировать
"при вводе данных в поле ДатаДоставки производится проверка на ее соответствие с текущей датой"
при этом событие ПриИзменении срабатывает...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

Проблема при проведении реализации УТ 11 - сообщение дата оплаты меньше даты документа

Автор AndreyBlacksmithРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 2701
Последний ответ 05 Фев 2015, 11:53
от AndreyBlacksmith
ЗУП Даты получения дохода в регистре налогового учета НДФЛ не ставятся(((?

Автор may_sergРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2874
Последний ответ 14 Июл 2011, 08:17
от may_serg
Установка даты запрета редактирования, как расширить выбором конкретных документов

Автор Саша ЛибертиРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 3059
Последний ответ 13 Июн 2014, 11:24
от Саша Либерти
Нет значка изменения даты в документе поступления товара, в 1с 8.3 , Розница 2.1 базовая

Автор genyfildРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 2682
Последний ответ 24 Фев 2015, 12:16
от genyfild
Определение даты получения дохода от реализации услуг при методе начисления

Автор newsРаздел Новости

Ответов: 0
Просмотров: 451
Последний ответ 19 Июн 2015, 15:19
от news

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
47 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 254
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal