Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 02:01
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как из внешней обработки обратиться к таблице выбранного документа?  (Прочитано 5034 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн вертер

  • *
  • Сообщений: 41
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-11-22
  • Сайт: 
УПП 8.2 во внешней обработке выбираю из списка документ УстановкаЦенНоменклатуры
после этого мне нужно табличную часть этого документа вывести на печать, в чем ошибка?
программа ругается на эту строку - ВыборкаПоСтрокам = ТабЧасть.Выбрать();
вот начало кода

Функция Печать() Экспорт
   
   
   Макет = ПолучитьМакет("Итог");

   ОбластьМакета = Макет.ПолучитьОбласть("Заголовок");
   ОбластьМакета.Параметры.ТекстЗаголовка = СсылкаНаОбъект;
   ТабДокумент.Вывести(ОбластьМакета);

   ОбластьШапкаНоменклатура   = Макет.ПолучитьОбласть("ШапкаТаблицы");
   
   ОбластьСтрокаНоменклатура  = Макет.ПолучитьОбласть("Строка|Номенклатура");
   ОбластьСтрокаТипЦен        = Макет.ПолучитьОбласть("Строка|Цена");
   ОбластьПодвалНоменклатура  = Макет.ПолучитьОбласть("Подписи");
   ОбластьВсего   = Макет.ПолучитьОбласть("Всего");
      
   ТабДокумент.Вывести(ОбластьШапкаНоменклатура);
   

   // Выведем таблицу.
   ТабЧасть=СсылкаНаОбъект.Товары;
   
       ВыборкаПоСтрокам = ТабЧасть.Выбрать();
   Пока ВыборкаПоСтрокам.Следующий() Цикл
      НоменклатураВыведена = Ложь;
      Выборка = ВыборкаПоСтрокам.Выбрать();
      Пока Выборка.Следующий() Цикл
         Если Не НоменклатураВыведена Тогда
            ОбластьСтрокаНоменклатура.Параметры.Заполнить(Выборка);
            ОбластьСтрокаНоменклатура.Параметры.Товар = СокрЛП(Выборка.Товар) + ФормированиеПечатныхФорм.ПредставлениеСерий(Выборка);
            ТабДокумент.Вывести(ОбластьСтрокаНоменклатура);
            НоменклатураВыведена = Истина;
         КонецЕсли;
   
         ТабДокумент.Присоединить(ОбластьСтрокаТипЦен);
         
         мВсего=мВсего+Выборка.Цена;
         

      КонецЦикла;
      
   КонецЦикла;
         
     ОбластьВсего.Параметры.ВсегоПоДокументу=мВсего;
         ТабДокумент.Вывести(ОбластьВсего);
   

   // Выведем подвал.
   
и тд


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Сильно не вникал как именно в самом документе подключаются ВПФ...
Во-первых, вашу обработку надо подключать в виде нового элемента в специальный справочник ВнешниеПечатныеФормы.
Во-вторых, в типовых ВПФ данные из документа (и из ТЧ в том числе) получаются запросом с фильтром Ссылка = СсылкаНаОбъект.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн chuevsf

  • Хочу! Хочу! Хочу! Мышь на палочке!
  • Глобальный модератор
  • *****
  • Сообщений: 1376
  • РЕПУТАЦИЯ: 345
  • КПД: 25%
  • Регистрация: 2010-07-08
    • Skype: chuevsf
  • Сайт: 
  • Профессия: Программист 1С
// Выведем таблицу.
   ТабЧасть=СсылкаНаОбъект.Товары;

Для Каждого ТекущаяСтрока Из ТабЧасть Цикл
Сообщить(ТекущаяСтрока. "Имя колонки");
   // Действия со строкой табличной части.

КонецЦикла;
А для макета напишешь сам.



Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4469
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 15901
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4195
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 617
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7734
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
166 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
36 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
28 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 160
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal