Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 21:59
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Детский вопрос по 1С 7.7  (Прочитано 5565 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн mark2011

  • *
  • Сообщений: 41
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-18
  • Сайт: 
  • Профессия: Ученик 1С
Вопрос сильно детский, понимаю,но....

В общем кинул на форму элемент "Текст". Назвал его "ВФ" (его идентификатор). Суть такая, мне нужно по кнопке выбрать файл и отобразить его в соответствующем поле. Как к этому полю только не обращался - ответ один: переменная ВФ не определена. Как так? Это же идентификатор, специально заданный.

Убрал значение "Текст" (то, что отображается в поле по умолчанию), в результате в поле стало писаться "<ВФ>". Но применение такой конструкции дало ошибку "Неопознанный оператор".... естественно, что заранее объявлять переменную ВФ смысла нет - это же объект должен быть по сути ))

Вот мой код:

Процедура Выбрать_Файл()

ИмяФайла = "";
ВФ = "";
ИмяКаталога = "";
ЗаголовокОкна = "Выберите файл для экспорта";
РасширениеФайла = "xml";

ФС.ВыбратьФайл(0, ИмяФайла, ИмяКаталога, ЗаголовокОкна, "Текст(*.xml)|*.xml", РасширениеФайла);
ВФ.Текст = "ssfsf";


КонецПроцедуры

А вот то, что выводит 1С-ка в результате этого кода (нажатие на кнопку происходит нормально, это сообщение выдаётся после выбора файла.

Цитировать
ВФ.Текст = "ssfsf";
{C:\DOCUMENTS AND SETTINGS\ADMIN\РАБОЧИЙ СТОЛ\TEST.ERT(12)}: Значение не представляет агрегатный объект (Текст)


Оффлайн mark2011

  • *
  • Сообщений: 41
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-18
  • Сайт: 
  • Профессия: Ученик 1С
Вот немножко модифицированный код, но суть от этого не поменялась :)

Процедура Выбрать_Файл()

ИмяФайла = "";
ВФ = "";
ИмяКаталога = "";
ЗаголовокОкна = "Выберите файл для экспорта";
РасширениеФайла = "xml";

Если (ФС.ВыбратьФайл(0, ИмяФайла, ИмяКаталога, ЗаголовокОкна, "Текст(*.xml)|*.xml", РасширениеФайла)=1) Тогда
ВФ.Текст = "ssfsf";
КонецЕсли

КонецПроцедуры

Оффлайн mark2011

  • *
  • Сообщений: 41
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-18
  • Сайт: 
  • Профессия: Ученик 1С
К сожалению не работает. Принцип понятен, но не существует полей "Заголовок", "Текст", Значение" - я их все перебрал :(

Оффлайн prog1c7.7

  • Модератор
  • *****
  • Сообщений: 784
  • РЕПУТАЦИЯ: 260
  • КПД: 33%
  • ну - да , ну - да...
  • Регистрация: 2010-10-20
  • Сайт: 
  • Профессия: Программист 1С

Перем НачКат, ФайлДанных;  
Процедура ВыборФайла()//Загрузка номеров нехватающих полисов из файла данных
Если ФС.ВыбратьФайл(0,ФайлДанных,НачКат,"Выберите файл для загрузки данных ...","Базы данных (*.xls)|*.xls")=1 Тогда
    ФайлДБ=НачКат+ФайлДанных;
КонецЕсли;
КонецПроцедуры

ФайлДБ только на форме.
Процедура ВыборФайла на кнопке висит


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
179 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 331
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal