Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 10:27
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Ошибка в модуле  (Прочитано 8111 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн master1104

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-07
  • Сайт: 
  • Профессия: Ученик 1С
{Документ.ЦС_Извещение(774,3)}: Неопознанный оператор
    <<?>>= Новый  СписокЗначений;
Что должно быть перед равно?


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Re: Ошибка в модуле
« Ответ #1: 22 Май 2011, 14:50 »
Должно быть имя вашего нового списка значений.
Его придумываете сами с учетом правил назначения имен переменным.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Re: Ошибка в модуле
« Ответ #2: 22 Май 2011, 15:54 »
Приведите нормально код, так же невозможно ничего понять.
Кусок кода с ошибочной строчкой в студию
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн master1104

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-07
  • Сайт: 
  • Профессия: Ученик 1С
Re: Ошибка в модуле
« Ответ #3: 22 Май 2011, 16:26 »
Процедура ОбработкаЗаполнения(Основание)
      ???    = Новый СписокЗначений;
   //хранит значения типов документов, которые будут заполнены
   спТипов.Добавить(Тип("ДокументСсылка.МЗ_БезвозмезднаяПередача"));
   спТипов.Добавить(Тип("ДокументСсылка.БСО_Списание"));
   спТипов.Добавить(Тип("ДокументСсылка.ИК_СписаниеИнвОбъектаБезвозмезднаяПередача"));
   спТипов.Добавить(Тип("ДокументСсылка.ИК_СписаниеСписком"));
   спТипов.Добавить(Тип("ДокументСсылка.МЗ_СписаниеЗабаланс"));
   спТипов.Добавить(Тип("ДокументСсылка.НПА_Списание"));
   спТипов.Добавить(Тип("ДокументСсылка.ОС_АрендаСписание"));
   спТипов.Добавить(Тип("ДокументСсылка.ОС_СписаниеБиблиотеки"));
   спТипов.Добавить(Тип("ДокументСсылка.ОС_СписаниеИнвОбъектаБезвозмезднаяПередача"));
   спТипов.Добавить(Тип("ДокументСсылка.ОС_СписаниеКапвложений"));
   спТипов.Добавить(Тип("ДокументСсылка.ОС_СписаниеСписком"));
   спТипов.Добавить(Тип("ДокументСсылка.ОСвОперУчетеСписание"));
   //входит ли текущий тип документа в список?
   Если спТипов.НайтиПоЗначению(ТипЗнч(Основание)) <> Неопределено Тогда
      // Заполнение шапки
      ВидПередачи = 2;
      ДокументОснование = Основание;
      Дата = Основание.Дата;
      Если (ТипЗнч(Основание) = Тип("ДокументСсылка.ОСвОперУчетеСписание") ИЛИ ТипЗнч(Основание) = Тип("ДокументСсылка.МЗ_СписаниеЗабаланс")) Тогда
         КВД = Перечисления.КВД.Бюджет;
      Иначе
         КВД = Основание.КВД;
      КонецЕсли;
      
      Если НЕ ТипЗнч(Основание) = Тип("ДокументСсылка.БСО_Списание") Тогда
         Получатель = Основание.Контрагент;
      КонецЕсли;
      
      // Заполнение ТЧ "Документ передачи"
      ДокПередачи = СоставДокументов.Добавить();
      ДокПередачи.ДокументПередачи = Основание;
   КонецЕсли;
КонецПроцедуры

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Re: Ошибка в модуле
« Ответ #4: 22 Май 2011, 16:37 »
А еще кусочек до ошибочной строки?
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн master1104

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-07
  • Сайт: 
  • Профессия: Ученик 1С
Re: Ошибка в модуле
« Ответ #5: 22 Май 2011, 16:46 »
Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
   Если ЭтоНовый() Тогда
      СтатусДокумента = 1;
   КонецЕсли;
   Если РежимЗаписи = РежимЗаписиДокумента.Проведение Тогда
      мНеЗачитыватьАвансыВыданныеАвтоматически = БухгалтерскийУчет.Получить_НеЗачитыватьАвансАвтоматически(Учреждение, Дата, "НеЗачитыватьАвансыВыданныеАвтоматически");
   КонецЕсли;   
КонецПроцедуры

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Re: Ошибка в модуле
« Ответ #6: 22 Май 2011, 16:53 »
Ну наверное вместо вопросов надо написать
спТипов...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Re: Ошибка в модуле
« Ответ #7: 22 Май 2011, 16:56 »
Именно)
Интересно, кто туда втулил вопросы...
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Re: Ошибка в модуле
« Ответ #8: 22 Май 2011, 17:05 »
тест на нашу профпригодность
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

При открытии обр-ки в "Предприятии" есть ошибка, а в "Отладке" нет

Автор proofetРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4544
Последний ответ 21 Сен 2011, 17:35
от proofet
ошибка "Невозможно обработать параметр "ПрофильПолномочийПользователя""

Автор lindeluРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 6102
Последний ответ 06 Июн 2012, 09:15
от lindelu
Синтаксическая ошибка "В" Номенклатура.Ссылка = <<?>> В ИЕРАРХИИ(&Ссылка)

Автор maskitoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4213
Последний ответ 28 Апр 2014, 15:53
от maskito
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8529
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
Ошибка при загрузке данных через (Обработка "Выгрузка и загрузка данных XML")

Автор Сергей_87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 8571
Последний ответ 26 Апр 2012, 23:08
от Dethmontt

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
46 Сообщений
oleg-x
44 Сообщений
andron81_81
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 262
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal