Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
21 Янв 2018, 17:45
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Заполнение Табличной Части документа  (Прочитано 2022 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Yeahkaterina

  • *
  • Сообщений: 22
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-03-16
  • Сайт: 
  • Профессия: Бухгалтер
Делаю внешнюю обработку для приходных кассовых ордеров. Необходимо, чтоб при нажатии на КНОПКУ1 в табличной части происходила свертка приходников по дате и кассе-(это работает). Далее,галкой отмечаются док-ты которые необходимо провести и по нажатию на кнопку ВЫПОЛНИТЬ создается новый документ "ОплатаОтНаселния", но только в развернутом состоянии(Для каждого отмеченного отдельный). Не могу заполнить все поля табличной части в док-те "ОплатаОтНаселения"...
подскажите пожалуйста



Процедура КнопкаВыполнитьНажатие(Кнопка)

Для Каждого Строка ИЗ ДокументыПриходники Цикл
Если Строка.Загрузить = Истина Тогда
НовыйДокумент = Документы.ОплатаОтНаселения.СоздатьДокумент();

ПараметрыОтбора = Новый Структура;
ПараметрыОтбора.Вставить("Дата", Строка.Дата);
ПараметрыОтбора.Вставить("Касса", Строка.Касса);
НайденыеСтроки = ДокументыПриходникиРазвернут.НайтиСтроки(ПараметрыОтбора);

Для каждого Элем Из НайденыеСтроки Цикл
ТЧ = НовыйДокумент.ДокументыПКО.Добавить();   
Тч.Дата = Элем.Дата;
Тч.Касса = Элем.Касса;

Тч.Сумма = ??????


КонецЦикла;

КонецЕсли;
КонецЦикла;


НовыйДокумент.ПолучитьФорму().Открыть();


КонецПроцедуры

Процедура Кнопка1Нажатие(Элемент)


ДокументыПриходники.Очистить();

Запрос = Новый Запрос;
Запрос.УстановитьПараметр("ДатаНачала", НачПериода);
Запрос.УстановитьПараметр("ДатаОкончания", КонецДня(КонПериода));
Запрос.УстановитьПараметр("Касса", Касса);
Запрос.УстановитьПараметр("НетОтбораПоКассе", Не ЗначениеЗаполнено(Касса));
Запрос.Текст = "ВЫБРАТЬ
|   ПриходныйКассовыйОрдер.Дата,
|   ПриходныйКассовыйОрдер.Касса,
|   ПриходныйКассовыйОрдер.СуммаДокумента КАК СуммаДокумента,
|   ПриходныйКассовыйОрдерРасшифровкаПлатежа.Ссылка,
|   ХозрасчетныйОбороты.НомерСтроки
|ПОМЕСТИТЬ Таблица
|ИЗ
|   РегистрБухгалтерии.Хозрасчетный.Обороты(&ДатаНачала, &ДатаОкончания, Запись, , , , , ) КАК ХозрасчетныйОбороты
|    ВНУТРЕННЕЕ СОЕДИНЕНИЕ Документ.ПриходныйКассовыйОрдер КАК ПриходныйКассовыйОрдер
|    ПО ХозрасчетныйОбороты.Регистратор = ПриходныйКассовыйОрдер.Ссылка
|    ВНУТРЕННЕЕ СОЕДИНЕНИЕ Документ.ПриходныйКассовыйОрдер.РасшифровкаПлатежа КАК ПриходныйКассовыйОрдерРасшифровкаПлатежа
|    ПО ХозрасчетныйОбороты.Регистратор = ПриходныйКассовыйОрдерРасшифровкаПлатежа.Ссылка
|ГДЕ
|   (ПриходныйКассовыйОрдер.Касса = &Касса
|    ИЛИ &НетОтбораПоКассе)
|;
|
|////////////////////////////////////////////////////////////////////////////////
|ВЫБРАТЬ
|   Таблица.Касса КАК Касса,
|   Таблица.СуммаДокумента КАК СуммаДокумента,
|   Таблица.Ссылка КАК Ссылка,
|   Таблица.Дата,
|   Таблица.НомерСтроки КАК Количество
|ИЗ
|   Таблица КАК Таблица";


ВыборкаДвижений = Запрос.Выполнить().Выбрать();

Пока ВыборкаДвижений.Следующий() Цикл
СтрокаДокРаз = ДокументыПриходникиРазвернут.Добавить();
СтрокаДок = ДокументыПриходники.Добавить();
СтрокаДокРаз.Дата = ВыборкаДвижений.Дата;
СтрокаДокРаз.Касса = ВыборкаДвижений.Касса;
СтрокаДокРаз.Сумма = ВыборкаДвижений.СуммаДокумента;
СтрокаДокРаз.Документ = ВыборкаДвижений.Количество;
СтрокаДокРаз.Количество = ВыборкаДвижений.Количество;

СтрокаДок.Дата = ВыборкаДвижений.Дата;
СтрокаДок.Касса = ВыборкаДвижений.Касса;
СтрокаДок.Сумма = ВыборкаДвижений.СуммаДокумента;
//СтрокаДок.Организация = ВыборкаДвижений.Организация;
СтрокаДок.Документ = ВыборкаДвижений.Количество;
СтрокаДок.Количество = ВыборкаДвижений.Количество;
//СтрокаДок.Контрагент = ВыборкаДвижений.Контрагент;
//СтрокаДок.Договор = ВыборкаДвижений.ДоговорКонтрагента;
//СтрокаДок.Абонент = ВыборкаДвижений.Абонент;
СтрокаДок.загрузить = Истина;
КонецЦикла;
ДокументыПриходники.Свернуть("Дата,Касса","Сумма,Документ");




КонецПроцедуры


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4593
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7874
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4925
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 9001
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
Фамилия руководителя в печатных формах документа "Акт сверки", "Акт об оказании"

Автор MKozzlikРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 7484
Последний ответ 03 Фев 2012, 17:27
от Dinah

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
100 Сообщений
AIFrame
66 Сообщений
alex0402
32 Сообщений
kiksi
26 Сообщений
pavl_vs
24 Сообщений
alexandr_ll
18 Сообщений
andron81_81
16 Сообщений
Norfolk
16 Сообщений
KOI8-R
14 Сообщений
MuI_I_Ika MuI_I_Ika
13 Сообщений

* Кто онлайн

  • Точка Гостей: 378
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal