Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
25 янв 2022, 05:22

Запрос

Автор Denis1010, 02 дек 2021, 16:39

0 Пользователей и 1 гость просматривают эту тему.

Denis1010

Добрый день всем, подскажите пожалуйста, что я делаю не так.
Нужно вытащить значения из ТЗ запросом, запрос создал, но в выборке пишет, что такого поле не обнаружено. Как правильно запросом тянуть данные из ТЗ документа?)
Заранее благодарю! Работаю на 1C 8.0.

Мой код:
Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
               | ТребованиеНаЗакупку.Ссылка КАК Ссылка,
               | ТребованиеНаЗакупку.ДанныеТребование.(
               | НомерСтроки КАК НомерСтроки,
               | ЕдИзм,
               | Отпущено,
               | Цена
               | ) // ТУТ ПРОБОВАЛ ПИСАТЬ (КАК Таблица), не помогло.
               |ИЗ
               | Документ.ТребованиеНаЗакупку КАК ТребованиеНаЗакупку
               |ГДЕ
               | ТребованиеНаЗакупку.СтатусДокумента = &СтатусДокумента
               | И ТребованиеНаЗакупку.ДанныеТребование.НаименованиеТоваров = &НаименованиеТоваров";
   Запрос.УстановитьПараметр("СтатусДокумента", "Забронировано");
   Запрос.УстановитьПараметр("НаименованиеТоваров", Стр.НаименованиеВыбракованного);
   
   Выборка = Запрос.Выполнить().Выбрать();
   
   Пока Выборка.Следующий() Цикл
           
Сообщить(Выборка.НомерСтроки); // ТАКЖЕ ПРОБОВАЛ Выборка.ДанныеТребование.НомерСтроки (тоже не работает)
   
   КонецЦикла;

LexaK

@Denis1010, попробуйте в цикле такой код использовать
                       Пока Выборка.Следующий() Цикл
   
   лкДанные = Выборка.ДанныеТребование.Выбрать();
   
                       Пока лкДанные.Следующий() Цикл
                           Сообщить(лкДанные.НомерСтроки); // ТАКЖЕ ПРОБОВАЛ Выборка.ДанныеТребование.НомерСтроки (тоже не работает)
                       КонецЦикла;
                           
                       КонецЦикла;
ответ Понравился? (в смысле пригодился?)

Denis1010

@LexaK, Спасибо, попробовал - работает)
Я так понимаю, чтоб пройтись по ТЗ, нужно делать выборку в выборке, верно?

LexaK

Цитата: Denis1010 от 03 дек 2021, 08:04@LexaK, Спасибо, попробовал - работает)
Я так понимаю, чтоб пройтись по ТЗ, нужно делать выборку в выборке, верно?
в данном случае/примере верно (зависит от того как построен запрос).
а вообще в 1С существует несколько вариантов получения данных и их обхода/обработки.
зависит от вас как вы что-то собираетесь реализовать/программировать.
ответ Понравился? (в смысле пригодился?)

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск