Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
27 ноя 2021, 11:22

Код узла не может быть пустым

Автор Lopol, 25 ноя 2021, 11:18

0 Пользователей и 1 гость просматривают эту тему.

Lopol

Ребят, не могу понять что он хочет.Хочу выполнить обмен данными, выдает это :
Код узла не может быть пустым
{ПланОбмена.Филиалы.МодульОбъекта(16)}:ЗаписьСообщения.НачатьЗапись(ЗаписьXML, Ссылка);
{Обработка.ОбменДанными.Форма.Форма.Форма(16)}:УзелОбъект.ЗаписатьСообщениеСИзменениями();
{Обработка.ОбменДанными.Форма.Форма.Форма(4)}:ОбменСФилиалами();

по причине:
Код узла не может быть пустым
Помогите пожалуйста

Lopol

&НаКлиенте
Процедура ВыполнитьОбмен(Команда) Экспорт
ОбменСФилиалами();
КонецПроцедуры

&НаСервереБезКонтекста
Процедура ОбменСФилиалами() Экспорт
ВыборкаУзлов = ПланыОбмена.Филиалы.Выбрать();Пока ВыборкаУзлов.Следующий() Цикл
// Произвести обмен данными со всеми узлами, кроме текущего (ЭтотУзел)
Если ВыборкаУзлов.Ссылка <> ПланыОбмена.Филиалы.ЭтотУзел() Тогда
УзелОбъект = ВыборкаУзлов.ПолучитьОбъект();
// Получить сообщение
УзелОбъект.ПрочитатьСообщениеСИзменениями();
// Сформировать сообщение
УзелОбъект.ЗаписатьСообщениеСИзменениями();
КонецЕсли;
КонецЦикла;
КонецПроцедуры



ef0din


Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск