Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
27 ноя 2021, 11:23

почему же не работает код??

Автор alexandervol, 22 ноя 2021, 18:30

0 Пользователей и 1 гость просматривают эту тему.

alexandervol

ну вроде все должно быть максимально просто и логично, а код не работает... Screenshot_16.pngScreenshot_17.png  &НаСервере
Процедура ОборудованиеПриИзмененииНаСервере1()
Если Элементы.Оборудование = Истина Тогда
Элементы.Картридж.Доступность = Ложь;
КонецЕсли;

КонецПроцедуры

&НаКлиенте
Процедура ОборудованиеПриИзменении(Элемент)
Если Элементы.Оборудование = Истина Тогда
Элементы.Картридж.Доступность = Ложь;
КонецЕсли;

КонецПроцедуры

Ивашка

сделай только на клиенте
&НаКлиенте
Процедура ОборудованиеПриИзменении(Элемент)
        Если Элементы.Оборудование Тогда
             Элементы.Картридж.Доступность = Ложь;
        КонецЕсли;
КонецПроцедуры

alexandervol

@Ивашка, теперь вот так

если первую галочку на оборудование ставить

Ивашка

структуру вашей формы покажите

alexandervol


Ивашка

@alexandervol,
&НаКлиенте
Процедура ОборудованиеПриИзменении(Элемент)
        Если Объект.Оборудование Тогда
             Элементы.Картридж.Доступность = Ложь;
        КонецЕсли;
КонецПроцедуры

alexandervol

@Ивашка, ого, работает, спасибо! только после снятия галочки (я добавил после Объект.Оборудование = истина) элемент картридж все равно заблокирован. это конечно не проблема, но можно как-то избежать блокировки после снятия галочки?

alexandervol

@alexandervol, &НаКлиенте
Процедура ОборудованиеПриИзменении(Элемент)
Если Объект.Оборудование = Истина
Тогда
             Элементы.Картридж.Доступность = Ложь;
Иначе
Элементы.Картридж.Доступность = Истина;
        КонецЕсли;
КонецПроцедуры
вот так работает теперь

antoneus

Любой код можно сократить как минимум на одну команду)

&НаКлиенте
Процедура ОборудованиеПриИзменении(Элемент)
     Элементы.Картридж.Доступность = не Объект.Оборудование;
КонецПроцедуры

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск