Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
27 ноя 2021, 12:25

Нужна помощь! Обновление данных при работе через браузер

Автор Алексей_1985_06, 19 ноя 2021, 19:33

0 Пользователей и 1 гость просматривают эту тему.

Алексей_1985_06

Сразу прошу прощенья если что-то не понимаю в данном вопросе!
Прошу помочь реализовать следующие:
1. Есть задачи которые ставит руководитель. В модуле формы процедура:

&НаКлиенте
Процедура ПослеЗаписи(ПараметрыЗаписи)
Оповестить("ОбновитьСписокЗадач");
КонецПроцедуры

2. В другой формы есть три реквизита с типом "Динамический список" с соответствующим запросом и отбором по статусу задачи. Все вроде бы работает нормально, но через браузер обновления данных не происходит при открытой форме (обновляется только после закрытия формы)

3. Как сделать чтобы при работе через браузер происходило обновления данных в Динамических списках, как это происходит при работе в толстом клиенте?
Код для обновления данных такой:
&НаКлиенте
Процедура ОбработкаОповещения(ИмяСобытия, Параметр, Источник)

Если  ИмяСобытия = "ОбновитьСписокЗадач" Тогда
Элементы.ДинамСписокОткрытые.Обновить();
Элементы.ДинамСписокВработе.Обновить();
Элементы.ДинамСписокВыполнено.Обновить();
КонецЕсли;

КонецПроцедуры

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск