Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
27 ноя 2021, 11:40

Заполнить ТЧ Документа из ТЧ справочника

Автор fin07, 13 ноя 2021, 10:06

0 Пользователей и 1 гость просматривают эту тему.

fin07

Добрый день!
Помогите пожалуйста разобраться.
Есть документ "Заказ на производство" с двумя ТЧ (ГотоваяПродукция и ПолуфабрикатыСобственногоПроизводства)
ТЧ Готовая Продукция содержит следующие строки (Номенклатура, Спецификация)
ТЧ ПолуфабрикатыСобственногоПроизводства содержит следующие строки (Номенклатура, количество).
В строке Спецификация из ТЧ Готовая продукция ссылка на справочник РесурсныеСпецификации в котором есть ТЧ МатериалыИУслуги, которая содержит следующие данные (Номенклатура и количество).
Нужно при нажатии на кнопку ЗаполнитьПФ получить табличную часть справочника Ресурсные спецификации для каждой строки из ТЧ документа ГотоваяПродукция и заполнить этими значениями ТЧ ПолуфабрикатыСобственногоПроизводства.
Пишу следующий код
&НаКлиенте
Процедура ЗаполнитьПФ(Команда)
   ПолучитьМатериалыПоСпецификации();
   КонецПроцедуры

&НаСервере
   Процедура ПолучитьМатериалыПоСпецификации()
   Спецификация=Элементы.ГотоваяПродукцияСпецификация;   
   Запрос = Новый Запрос;
   Запрос.Текст =
      "ВЫБРАТЬ
      |   РесурсныеСпецификации.МатериалыИУслуги.(
      |      Номенклатура КАК Номенклатура,
      |      Количество КАК Количество
      |   ) КАК МатериалыИУслуги,
      |   РесурсныеСпецификации.Ссылка КАК Ссылка
      |ИЗ
      |   Справочник.РесурсныеСпецификации КАК РесурсныеСпецификации
      |ГДЕ
      |   РесурсныеСпецификации.Ссылка = &Ссылка";
          
   Запрос.УстановитьПараметр("Ссылка", Спецификация);   
   Выборка = Запрос.Выполнить().Выбрать();
      
   Пока Выборка.Следующий() Цикл
      строка=объект.ПолуфабрикатыСобственногоПроизводства.ДобавитьСтроку();
      строка.номенклатура=Выборка.Номенклатура;
      Строка.количество= Выборка.количество;
   КонецЦикла;
      
   КонецПроцедуры

Ругается по причине:
{(10, 31)}: Неверные параметры в операции сравнения. Нельзя сравнивать поля
 неограниченной длины и поля несовместимых типов.
РесурсныеСпецификации.Ссылка <<?>>= &Ссылка

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск