Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
27 ноя 2021, 11:53

Список выбора в УФ 1с: Предприятие 8.3

Автор Изо_льда, 11 ноя 2021, 08:13

0 Пользователей и 1 гость просматривают эту тему.

Изо_льда

Здравствуйте.

На форме в табличной части есть реквизиты "Действие" и "Количество". Он является списком выбора. Список заполняется значениями из свойств формы.
В списке выбора двенадцать значений. Также есть на форме кнопка "Заполнить". При нажатии на кнопку если значение количества меньше нуля, то действие должно подставится 1. Если больше нуля, то действие 12.

Пробовала записать колонку "Действие" в таблицу значений и оттуда выбирать нужные значения. Но не вышло. Таблица значений не заполняется.

Изо_льда

Тип клиента: тонкий клиент.
Ошиблась. Не в таблицу значений загружаю,а в список значений.

antoneus

Ничего не понял.

>На форме в табличной части есть реквизиты "Действие" и "Количество". Он является списком выбора.

Кто он?

Что такое "Действие 1" и "действие 12"? А остальные 10 где и зачем нужны?

Изо_льда

@antoneus

"Действие" является списком выбора. Количество - это число.

Остальные десять нужны для другого.

Список выбора выглядит примерно так:
Значение "1" Представление "Действие 1"
Значение "2" представление "Действие 2"
...
Значение "11" Представление "Действие 11"
Значение "12" Представление "Действие 12"

antoneus


А если количество равно нулю?

Для Каждого ТекСтрока из ТабличнаяЧасть Цикл
    Индекс = Неопределено;
    Если ТекСтрока.Количество < 0 Тогда
        Индекс = 0
    ИначеЕсли ТекСтрока.Количество > 0 Тогда
        Индекс = 11
    КонецЕсли;
    Если Индекс <> Неопределено Тогда
        ТекСтрока.Действие = Элементы.ТабличнаяЧастьДействие.СписокВыбора[Индекс].Значение
    КонецЕсли;
КонецЦикла;

Изо_льда

@antoneus, всё, разобралась. Спасибо вам за ответ!

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск