Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
27 ноя 2021, 11:15

Как выбрать нужный реквизит из ТЧ документа 8.3?

Автор TataRus, 11 ноя 2021, 08:01

0 Пользователей и 1 гость просматривают эту тему.

TataRus

Добрый день. Имеется внешняя обработка, в которой реализован выбор Договоров Контрагента из различных мест документа. Всё работает, но не так, как нужно. А нужно, чтобы при переборке табчасти ВидыСубконто, если среди видов субконто есть ДоговорыКонтрагентов, запоминался номер строки с этим видом субконто, и, если этот номер не 0, тогда получить значение реквизита документа СубконтоКт с номером равным номеру субконто ДоговорыКонтрагентов. И ещё, как сделать проверку на пустое значение для каждой строчки табчасти? Буду рада любой помощи, сама я окончательно запуталась.2121.jpg

alexandr_ll

@TataRus, Условие на сравнение видов субконто на счете ссылке на справочник договоры контрагентов некорректно. Это разные объекты.https://forum.infostart.ru/forum9/topic129838/

TataRus

@alexandr_ll, этот кусок кода, как раз и нужно заменить, чтобы выполнялась нужная мне задача. Пока пришла к такому, но в цикл не заходит почему-то



Если Документ.СчетУчетаРасчетовСКонтрагентом.ВидыСубконто.Количество() > 0  Тогда                                                             

                                         
                               Для каждого СтрТаблицы из Документ.СчетУчетаРасчетовСКонтрагентом.ВидыСубконто Цикл

                                               Если СтрТаблицы.НомерСтроки = ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.Договоры Тогда

                                                               СтрокаСубконто = СтрТаблицы.НомерСтроки;

                                                               Если СтрокаСубконто <> 0 Тогда

                                                                    НовСтр = Объект.ТабЧасть.Добавить();

                                                                              НовСтр.ДоговорыДокумента = Документ["СубконтоКт" + СтрокаСубконто];

                                                                    НовСтр.Справка = "Счет";
                                           

                                                               КонецЕсли;

                                               КонецЕсли;

                                               КонецЕсли

                                 КонецЦикла;

                               КонецЕсли;     

TataRus


Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск