Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
27 ноя 2021, 10:43

1с 8.3 Поле с видом календарь (УФ)

Автор illiona, 08 ноя 2021, 06:47

0 Пользователей и 1 гость просматривают эту тему.

illiona

Добрый день. Если Поле с видом календарь при активизации даты помечаю дату для раскрашивания, то раскрашивается только после закрытия и открытия формы,т.е. ПриВыводеПериода.
&НаКлиенте
Процедура КалендарьПолныйПриАктивизацииДаты(Элемент)
   
    Если ЭтаФорма.СписокДат.НайтиПоЗначению(Элементы.КалендарьПолный.ВыделенныеДаты[0]) = Неопределено Тогда
        ЭтаФорма.СписокДат.Добавить(Элементы.КалендарьПолный.ВыделенныеДаты[0]);
    Иначе
        НайденныйЭлемент = СписокДат.НайтиПоЗначению(Элементы.КалендарьПолный.ВыделенныеДаты[0]);
        ЭтаФорма.СписокДат.Удалить(НайденныйЭлемент);
    КонецЕсли;
    //ОформлениеПериода = Дата(1,1,1);
    //КалендарьПолныйПриВыводеПериода(Элемент,ОформлениеПериода);
   
КонецПроцедуры


&НаКлиенте
Процедура КалендарьПолныйПриВыводеПериода(Элемент, ОформлениеПериода)
   
     Для Каждого ДатаПериода Из ОформлениеПериода.Даты Цикл
      Если СписокДат.НайтиПоЗначению(ДатаПериода.Дата) <> Неопределено Тогда
           ДатаПериода.ЦветФона = webЦвета.БледноЗеленый;
      КонецЕсли;
     КонецЦикла;
КонецПроцедуры

Подскажите как сделать, чтоб календарь обновлялся, после активизации даты, т.е. срабатывала при выводе периода

ls600

вроде есть метод Обновить()

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск