Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
27 ноя 2021, 12:27

Не может определить перечисления, определяет как переменную

Автор Lopol, 03 ноя 2021, 17:53

0 Пользователей и 1 гость просматривают эту тему.

Lopol

Здраствуйте!Не так давно начал изучать 1с. Справочник : Автомобили , хочу добавить приколюху такую, чтобы пользователь выбирал Формат номера автомобиля, и дальше уже вводил как есть номер определенного государства , сейчас покажу

&НаКлиенте
Процедура ФорматНомераПриИзменении(Элемент)
Если ФорматНомера = Перечисления.ФорматНомера.РБ Тогда
ЭлементыФормы.Наименование.Маска = "9999 XX-9";
ИначеЕсли ФорматНомера = Перечисления.ФорматНомера.РФ Тогда 
ЭлементыФормы.Наименование.Маска = "X 999 XX - 999";
Иначе
ЭлементыФормы.Наименование.Маска = "";
КонецЕсли;


КонецПроцедуры

Но он выдает ошибку, в которой я не в силах разобраться (Пробовал два дня)
Помогите пожалуйста
"
{Справочник.Автомобили.Форма.ФормаЭлемента.Форма(4,7)}: Переменная не определена (ФорматНомера)
Если <<?>>ФорматНомера = Перечисления.ФорматНомера.РБ Тогда (Проверка: Тонкий клиент)
{Справочник.Автомобили.Форма.ФормаЭлемента.Форма(6,12)}: Переменная не определена (ФорматНомера)
ИначеЕсли <<?>>ФорматНомера = Перечисления.ФорматНомера.РФ Тогда (Проверка: Тонкий клиент)
{Справочник.Автомобили.Форма.ФормаЭлемента.Форма(4,22)}: Переменная не определена (Перечисления)
Если ФорматНомера = <<?>>Перечисления.ФорматНомера.РБ Тогда (Проверка: Тонкий клиент)
{Справочник.Автомобили.Форма.ФормаЭлемента.Форма(6,27)}: Переменная не определена (Перечисления)
ИначеЕсли ФорматНомера = <<?>>Перечисления.ФорматНомера.РФ Тогда (Проверка: Тонкий клиент)
{Справочник.Автомобили.Форма.ФормаЭлемента.Форма(5,3)}: Переменная не определена (ЭлементыФормы)
<<?>>ЭлементыФормы.Наименование.Маска = "9999 XX-9"; (Проверка: Тонкий клиент)
{Справочник.Автомобили.Форма.ФормаЭлемента.Форма(7,3)}: Переменная не определена (ЭлементыФормы)
<<?>>ЭлементыФормы.Наименование.Маска = "X 999 XX - 999"; (Проверка: Тонкий клиент)
{Справочник.Автомобили.Форма.ФормаЭлемента.Форма(9,3)}: Переменная не определена (ЭлементыФормы)
<<?>>ЭлементыФормы.Наименование.Маска = ""; (Проверка: Тонкий клиент
"

Ивашка

так как у тебя упр.формы, то  управ.формах, не элементыформы, а элементы, и в управ.формах к реквизитам обращаются через Объект
&НаКлиенте
Процедура ФорматНомераПриИзменении(Элемент)
    Если Объект.ФорматНомера = ПредопределенноеЗначение("Перечисление.ФорматНомера.РБ") Тогда
        Элементы.Наименование.Маска = "9999 XX-9";
    ИначеЕсли Объект.ФорматНомера = ПредопределенноеЗначение("Перечисление.ФорматНомера.РФ") Тогда 
        Элементы.Наименование.Маска = "X 999 XX - 999";
    Иначе
        Элементы.Наименование.Маска = "";
    КонецЕсли;
   

КонецПроцедуры

Lopol

Цитата: Ивашка от 03 ноя 2021, 18:12так как у тебя упр.формы, то  управ.формах, не элементыформы, а элементы, и в управ.формах к реквизитам обращаются через Объект
&НаКлиенте
Процедура ФорматНомераПриИзменении(Элемент)
    Если Объект.ФорматНомера = ПредопределенноеЗначение("Перечисление.ФорматНомера.РБ") Тогда
        Элементы.Наименование.Маска = "9999 XX-9";
    ИначеЕсли Объект.ФорматНомера = ПредопределенноеЗначение("Перечисление.ФорматНомера.РФ") Тогда 
        Элементы.Наименование.Маска = "X 999 XX - 999";
    Иначе
        Элементы.Наименование.Маска = "";
    КонецЕсли;
   

КонецПроцедуры
Cпасибо большое!А где мне лучше будет почитать или даже посмотреть видео про упрощенные формы?

Ивашка

@Lopol, есть видосики у Ильи Леонтьева про управляемые формы, можешь их посмотреть, книга про 1с автор радченко, много ресурсов

Lopol


Ивашка


Теги: помощь 

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск