Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
27 ноя 2021, 11:52

Копирование с одной ТЗ в другую

Автор Denis1010, 01 ноя 2021, 23:51

0 Пользователей и 1 гость просматривают эту тему.

Denis1010

Доброй ночи. У меня есть ТЗСтаж, и из этой ТЗ мне нужно скопировать все строки со значениями с колонки "ТабельныйНомер", в другую ТЗ.
Написал вот такой код, но выдаёт ошибку "Метод объекта не обнаружен (скопировать)". Не могу понять в чём моя ошибка. Благодарен каждому за помощь!

&НаСервере
Процедура СкопироватьНаСервере()

ТЗ1 = Новый ТаблицаЗначений;
ТЗ1 = ТЗСтаж.Скопировать("ТабельныйНомер");

КонецПроцедуры

&НаКлиенте
Процедура Скопировать(Команда)
СкопироватьНаСервере();
КонецПроцедуры

ls600


Denis1010

Спасибо, решил уже свою проблему, всё оказалось намного проще)
Для каждого тзСтрока Из ТЗСтаж Цикл

ЗаполнитьЗначенияСвойств(ТЗТабельныеНомера.Добавить(), тзСтрока);

КонецЦикла;

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск