Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
27 ноя 2021, 10:59

Партийный учет

Автор shareware, 24 окт 2021, 07:28

0 Пользователей и 1 гость просматривают эту тему.

shareware

Помогите понять, как это происходит и как правильно нужно описать обработчик. Есть ПриходнаяНакладная и РасходнаяНакладная. Есть регистр накопления ОстатокМатериала. Для приходной установил вид движения приход и все ок. Для расходной установил Расход.

Как сделать так, чтобы перед тем как создалась запись в регистре накоплений от расходной накладной, проверялось, существует ли достаточное количество товара. И как корректно указать то, из какой партии была списана недостающее количество товара

Я сейчас имею такой подобный Г**нокод, который работает некорректно из за неправильного запроса и неправильного цикла. Не знаю как сделать правильно


Процедура ОбработкаПроведения(Отказ, Режим)
Запрос = Новый Запрос;
Запрос.Текст = "SELECT
               | ОстаткиНоменклатурыОстатки.Партия,
               | SUM(ОстаткиНоменклатурыОстатки.КоличествоОстаток) as КоличествоОст,
               | SUM(ОстаткиНоменклатурыОстатки.СуммаОстаток) as Сумма,
               | ОстаткиНоменклатурыОстатки.Номенклатура
               |FROM
               | РегистрНакопления.ОстаткиНоменклатуры.Остатки as ОстаткиНоменклатурыОстатки
   |GROUP BY
   | ОстаткиНоменклатурыОстатки.Партия, ОстаткиНоменклатурыОстатки.Номенклатура";
   
   
ЗапросВыборкаДанных = Запрос.Выполнить().Выбрать();


Пока ЗапросВыборкаДанных.Следующий() Цикл
Движения.ОстаткиНоменклатуры.Записывать = Истина;
Для Каждого ТекСтрокаСписокНоменклатуры Из СписокНоменклатуры Цикл
Движение = Движения.ОстаткиНоменклатуры.Добавить();
Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
Движение.Период = Дата;

  Движение.Партия = ЗапросВыборкаДанных.Партия;


Движение.Номенклатура = ТекСтрокаСписокНоменклатуры.Номенклатура;
Движение.Количество = ТекСтрокаСписокНоменклатуры.Количество;
Движение.Сумма = ТекСтрокаСписокНоменклатуры.Сумма;
КонецЦикла;
КонецЦикла;
КонецПроцедуры

Помогите разобраться с этой темой. 2 День сижу понять не могу. Гуглил, ответы есть, но разобраться они мне не помогли.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск