Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
27 ноя 2021, 12:29

отказ от проведения Документа по условию

Автор blade_snl, 20 окт 2021, 20:17

0 Пользователей и 1 гость просматривают эту тему.

blade_snl

подскажите, почему не срабатывает...

&НаКлиенте
Процедура ПередЗаписью(Отказ, РежимЗаписи)
Если РежимЗаписи = РежимЗаписиДокумента.Проведение Тогда
Если НЕ Объект.ДокументОтработан Тогда
Сообщить("Заявку можно провести только после выполнения процедуры по созданию подчиненных Документов.");
Отказ = Истина;
КонецЕсли;
КонецЕсли;
КонецПроцедуры

условие "РежимЗаписи = РежимЗаписиДокумента.Проведение" всегда дает ЛОЖЬ, хотя при Останове проверяю значения параметров - "РежимЗаписи" показывает как положено Структуру со значением "Проведение"...

blade_snl

@blade_snl, разобрался сам...
РежимЗаписи - это структура, потому нужно писать так:

РежимЗаписи.РежимЗаписи = РежимЗаписиДокумента.Проведение

но есть другой вопрос.

событием "ПередЗаписью" я отлавливаю момент попытки проведения Документа по нажатию кнопки на форме "Провести и закрыть".... но если пользователь в списке документов правой кнопкой мышки через контекстное меню выберет "Провести" - это событие не будет отработано.

как мне вписать проверку в этом случае?

wise

(1) в модуде объекта ТОЖЕ есть процедура ПередЗаписью, которая сработает в ЛЮБОМ случае.
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

blade_snl

Цитата: wise от 21 окт 2021, 09:38(1) в модуде объекта ТОЖЕ есть процедура ПередЗаписью, которая сработает в ЛЮБОМ случае.

а я могу ее тоже прописать с нужным мне условием?

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск