Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
27 ноя 2021, 11:37

Получение первой строки ТЗ

Автор Denis1010, 18 окт 2021, 13:34

0 Пользователей и 1 гость просматривают эту тему.

Denis1010

Добрый день всем, я разрабатываю одну обработку, и в ходе возникла проблема. Есть ТЗ, которая заполняется по нажатию на кнопку.
Поля ТЗ следующие:
ЛичныйНомер
ФИО
ДатаНачала
ДатаКонец
Сумма

Проблема следующая, мне нужно взять первую строку с ТЗ, а то есть значение колонки "Сумма", только из первой строки, и затем уже засунуть в код на условие это значение (обязательно чтоб строка была 1)
Пример как должно быть:

Если ПерваяСтрока = "100" Тогда
//мои действия
КонецЕсли;

Если я указываю в условие название колонки, то мне выдаёт на результате все строки с этим значением, а мне нужно получить только значение колонки из первой строки. Пытался вытащить первую строку следующим кодом, но ничего не помогло(

ПерваяСтрока = ТЗТест[0];
ПерваяСтрока = ТЗТест.Получить(0);

ИначеЕсли ПерваяСтрока = Строка.Сумма = "100" Тогда
//мои действия
КонецЕслиl;

Благодарю каждого кто поможет!)



LexaK

(вы не указали какие у вас формы, режим запуска и т.д. - все это влияет на код)
да самое простое обход в цикле всегда начинается с первой строки


&НаКлиенте
Процедура КомандаОбработать(Команда)
//Обработка по кнопке
Для каждого лкСтр Из ТЗТест Цикл
ОбработкаСуммы(лкСтр.Сумма);
Прервать;
КонецЦикла;

КонецПроцедуры
 
&НаСервере
Процедура ОбработкаСуммы(лкСумма)

Если лкСумма < 100 Тогда
//Ваша обработка
Иначе
//Ваша обработка
КонецЕсли;

КонецПроцедуры
 
ответ Понравился? (в смысле пригодился?)

antoneus

ПерваяСтрока = ТЗТест[0];

Если ПерваяСтрока.Сумма = 100 Тогда
//мои действия
КонецЕслиl;

Denis1010

@antoneus, пробовал, выдаёт ошибку "Получение элемента по индексу для значения не определено" :(

antoneus

Вместо ТЗТест подставить имя реквизита с тз. А что такое ТЗТест тогда?
И не забыть проверку на заполненность.

Если ТЗТест.Количество() <> 0

ShakirovSergey


Если ТЗТест.Количество() > 0 Тогда

СуммаПервойСтроки = ТЗТест[0].Сумма;

КонецЕсли;


Теги:

Похожие темы (5)

65213

Ответов: 5
Просмотров: 7267

4510

Ответов: 0
Просмотров: 1930

Рейтинг@Mail.ru Rambler's Top100

Поиск