Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
27 ноя 2021, 12:40

Как сделать отбор в форме выбора по таблице

Автор Lakord, 14 окт 2021, 13:12

0 Пользователей и 1 гость просматривают эту тему.

Lakord

Есть справочник аналоги номенклатуры с таблицей АналогичнаяНоменклатура, в которой колонка-ссылка на справочник номенклатуры.
Аналоги.png

И есть второй справочник с таблицей Запчасти, в которой есть колонка-ссылка на справочник Номенклатура и Колонка-ссылка на справочник аналоги
Схемы.png

Пытаюсь сделать, чтобы после выбора номенклатуры в таблице Запчасти, в колонке Аналоги загружалась форма выбора с отбором по выбранной номенклатуре. Т.е. отображались только аналоги у которых в табличной части есть выбранная номенклатура.

&НаСервере
Функция ВыборкаДанных ()
   НужныеДанные = Новый СписокЗначений;
   Выборка = Справочники.Аналоги.Выбрать();
   Пока Выборка.Следующий() Цикл
   
   Если Выборка.АналогичнаяНоменклатура.НайтиСтроки(Объект.Запчасти.Номенклатура)<> 0 Тогда
        НужныеДанные.Добавить(Выборка.Ссылка);
КонецЕсли;                                   

   КонецЦикла;
     Возврат НужныеДанные;
КонецФункции

Может есть идеи как реализовать?

LexaK

ответ Понравился? (в смысле пригодился?)

Lakord

Цитата: LexaK от 14 окт 2021, 13:29@Lakord, есть идея написать запрос!

Запрос в плане пробежать табличную часть в аналогах?

LexaK

1.запросить Аналоги, у которых в ТЧ есть искомая номенклатура
2.выгрузить ссылки этих Аналогов в СписокЗначений
3.дать пользователю выбрать из этого списка нужный
ответ Понравился? (в смысле пригодился?)

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск