Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 05:28
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Перемещение товара  (Прочитано 6726 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ADRENALIN1986

  • *
  • Сообщений: 44
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-01-22
  • Сайт: 
  • Профессия: Программист 7.7
Проблема вот в чем при перемещении товара со склада на склад при переоценке, когда я нажимаю провести выскакивает ошибка

 Операция.Дебет.Контрагенты=Владелец;
{Документ.ПеремещениеТовараНаКомиссии.Модуль Документа(66)}: Для счета 41.3 вид субконто Контрагенты неопределен!

В чем ошибка и как ее исправить помогите пожалуйста.......

1С предприятие 7.7 Беларусь конфигурация Юкола





Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
Конфигурация типовая?
А программа говорит о том, что на счете 41.3 субконто "Контрагенты" нет.

Оффлайн ADRENALIN1986

  • *
  • Сообщений: 44
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-01-22
  • Сайт: 
  • Профессия: Программист 7.7
Да типовая а как их добавить или как изменить что бы провелся данный документ помогите плиз очень нужно

Оффлайн prog1c7.7

  • Модератор
  • *****
  • Сообщений: 784
  • РЕПУТАЦИЯ: 260
  • КПД: 33%
  • ну - да , ну - да...
  • Регистрация: 2010-10-20
  • Сайт: 
  • Профессия: Программист 1С
из конфигуратора , заходите в план счетов и добавляете субконто

Оффлайн ADRENALIN1986

  • *
  • Сообщений: 44
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-01-22
  • Сайт: 
  • Профессия: Программист 7.7
Я извеняюсь за новясчивость пожалуйста объясните поподробней ... есть аспекты которые я не вполне понимаю.. И какой именно субконто нужно добавлять??? Пожалуйста помогите буду дожен.

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
Я извеняюсь за новясчивость пожалуйста объясните поподробней ... есть аспекты которые я не вполне понимаю.. И какой именно субконто нужно добавлять??? Пожалуйста помогите буду дожен.
Открываешь план счетов. Находишь нужный счет. Выбираешь субконто и подставляешь туда (из списка) "контрагенты"

Оффлайн ADRENALIN1986

  • *
  • Сообщений: 44
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-01-22
  • Сайт: 
  • Профессия: Программист 7.7
Добавил теперь появилась ошибка следующая

Операция.Записать();
{Документ.ПеремещениеТоваровНаКомиссии.Модуль Документа(85)}: Балансовый счет не может корреспондировать с пустым счетом!(проводка 1)

Это просто ужас.Я извеняюсь а как исправить это....

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
Это говорит, что корреспондирующего счета нет. Все реквизиты заполнены у документа?

Оффлайн ADRENALIN1986

  • *
  • Сообщений: 44
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-01-22
  • Сайт: 
  • Профессия: Программист 7.7
Да все вот я думаю в чем проблема не подскажите

Оффлайн ADRENALIN1986

  • *
  • Сообщений: 44
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-01-22
  • Сайт: 
  • Профессия: Программист 7.7
Вот код не мог вставить отдельным документом поэтому если он нужен выкладываем если нет то  удалите


// ********************
//
Процедура ОбработкаПроведения()
   СчПрод = СчетПоКоду("43");
   Сч41_1 = СчетПоКоду("41.1");
   Сч41_4 = СчетПоКоду("41.4");
   Сч41_3 = СчетПоКоду("41.3");
   Сч004 = СчетПоКоду("004");
    КоличествоНаСкладе = 0;
   
   СписокТоваров = СоздатьОбъект("СписокЗначений");
   ВыгрузитьТабличнуюЧасть(СписокТоваров, "Товар");
   СписокПартий  = СоздатьОбъект("СписокЗначений");
   ВыгрузитьТабличнуюЧасть(СписокПартий, "Партия");
   
   БухИт = СоздатьОбъект("БухгалтерскиеИтоги");
   БухИт.ИспользоватьСубконто(ВидыСубконто.Номенклатура, СписокТоваров, 2);
   БухИт.ИспользоватьСубконто(ВидыСубконто.МестаХранения,Склад,,2);
   БухИт.ИспользоватьСубконто(ВидыСубконто.Контрагенты,Владелец,,2);
   БухИт.ИспользоватьСубконто(ВидыСубконто.ПартииТовара, СписокПартий, 2);
   БухИт.ВыполнитьЗапрос(ТекущийДокумент(),,"004",,,,,5);  // пс

   ВыбратьСтроки();
   Пока ПолучитьСтроку() = 1 Цикл
      Если Товар.ТипНоменклатуры.Выбран() = 0 Тогда
         Сообщить("Строка- "+НомерСтроки+": Не указан тип номенклатуры для товара: "+Товар);
         Продолжить;
      КонецЕсли;
      
      СчетУчета = "";
      Если Товар.ТипНоменклатуры = Перечисление.ТипыНоменклатуры.Продукция Тогда
      СчетУчета = СчПрод; //Сч43;
      ИначеЕсли Товар.ТипНоменклатуры = Перечисление.ТипыНоменклатуры.Товар Тогда
         Если Товар.ТипТовара = Перечисление.ТипыТоваров.НаКомиссии Тогда            //юис
         СчетУчета = Сч41_3;
         КонецЕсли;
      КонецЕсли;
      
      Если ПустоеЗначение(СчетУчета) = 1 Тогда //счет учета не выбран
         Сообщить("Строка- "+НомерСтроки+": Документ не предназначен для номенклатуры типа: "+Товар.ТипНоменклатуры);
         Продолжить;
      КонецЕсли;
      
      Если БухИт.ПолучитьСчет(,СчетУчета) = 1 Тогда
         Если БухИт.ПолучитьСубконто(1,,Товар) = 1 Тогда
            Если  БухИт.ПолучитьСубконто(2,,Партия) = 1 Тогда
               СуммаНаСкладах     = БухИт.СНД("С");
               КоличествоНаСкладе = БухИт.СНД("К");
            КонецЕсли;
         КонецЕсли;
      КонецЕсли;
      
      //Если (КоличествоНаСкладе  < Количество) и (КоличествоНаСкладе=0) Тогда
      //   Сообщить("Строка- "+НомерСтроки+": На складе "+КоличествоНаСкладе+" "+Товар.ЕдиницаИзмерения+
      //   " из необходимых "+Количество+" "+Товар.ЕдиницаИзмерения+" товара "+Товар);
      //   Продолжить;
      //КонецЕсли;
      //Стоимость = СуммаНаСкладах/КоличествоНаСкладе*Количество;
       
      КоличествоНаСкладе = 0;
      
         Операция.НоваяПроводка();
         Операция.Дебет.Счет = СчетУчета;
         Операция.Дебет.Номенклатура  = Товар;
         Операция.Дебет.ПартииТовара  = Партия;
         Операция.Дебет.Контрагенты = Владелец;
          операция.Дебет.МестаХранения = Склад2;
         
         
         Операция.НоваяПроводка();
         Операция.Кредит.Счет = СчетУчета;
         Операция.Кредит.Номенклатура  = Товар;
         Операция.Кредит.ПартииТовара  = Партия;
         Операция.Кредит.Контрагенты = Владелец;
          операция.Кредит.МестаХранения = Склад;

         Операция.СодержаниеПроводки = "Перемещение товара";
         Операция.Сумма      = Стоимость;
         Операция.Количество = Количество;
      
   КонецЦикла;
   Операция.ДатаОперации = ДатаДок;
   Операция.Содержание = "Перемещение товара";
   Операция.СуммаОперации = Итог("Стоимость");
   Операция.Записать();

КонецПроцедуры


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
180 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
29 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 211
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal