Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
17 янв 2022, 11:11

Загрузка картинки в 1с 8.3 управляемое приложение

Автор lazo, 22 сен 2021, 14:48

0 Пользователей и 1 гость просматривают эту тему.

lazo

Здравствуйте.
Если кто может помогите выяснить вопрос с загрузкой картинки в ФормуКонстант...
Возможно ли это сделать?
в модуле-


&НаКлиенте
Процедура ЗагрузитьКартинку(Команда)
   // Вставить содержимое обработчика.
   
   Оповещение = Новый ОписаниеОповещения("ЗагрузитьКартинкуЗавершение",ЭтотОбъект);
   НачатьПомещениеФайла(Оповещение,,,Истина,УникальныйИдентификатор);
   

КонецПроцедуры

&НаКлиенте
Процедура ЗагрузитьКартинкуЗавершение(Результат,Адрес,ВыбранноеИмяФайла,ДополнительныеПараметры) Экспорт
   
   если НЕ Результат Тогда
      Возврат;
   КонецЕсли;
   АдресКартинки =  Адрес;
   Модифицированность = Истина;
КонецПроцедуры
&НаСервере
Процедура ПередЗаписьюНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)
   //// Вставить содержимое обработчика
------------------------------------------------------------------------------ здесь непонятно как правильно сделать
      КонстантаМоя = ТекущийОбъект.Картинка;
      Если ЭтоАдресВременногоХранилища(АдресКартинки) Тогда
      КонстантаМоя = Новый ХранилищеЗначения(ПолучитьИзВременногоХранилища(АдресКартинки));
------------------------------------------------------------------------------ 
   КонецЕсли;
КонецПроцедуры

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
   // Вставить содержимое обработчика.
------------------------------------------------------------------------------- здесь тоже как правильно указать
      КонстантаМоя  = НаборКонстант.Картинка;   
 АдресКартинки = ПолучитьНавигационнуюСсылку(КонстантаМоя, "Картинка");
--------------------------------------------------------------------------------
КонецПроцедуры

Картинка с формой и объектами приложил...

Ошибка: Поле объекта не обнаружено (Картинка)
{ОбщаяФорма.ФормаКонстант.Форма(33)}:      КонстантаМоя  = НаборКонстант.Картинка;

Буду благодарен кто поможет в данном вопросе. 


Теги:

Похожие темы (5)

41531

Ответов: 0
Просмотров: 1080

59320

Ответов: 5
Просмотров: 2387

61516

Ответов: 7
Просмотров: 1639

67488

Ответов: 3
Просмотров: 967

Рейтинг@Mail.ru Rambler's Top100

Поиск