Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
19 окт 2021, 12:21

Множественный выбор

Автор Denis1010, 21 сен 2021, 16:46

0 Пользователей и 1 гость просматривают эту тему.

Denis1010

Добрый вечер, интересует следующий вопрос)
Имеется форма элементов, на ней есть поле ввода, с ссылкой на справочник. С помощью этой ссылки, я выбираю нужную группу и вывожу данные в ТЗ. Помогите пожалуйста разобраться, как я могу сделать множественный выбор, а не только 1 элемента или группы из списка выбора по ссылке в поле ввода?
Пробовал следующие (код ниже), но не помогло. Заранее спасибо всем!))
Процедура ПолеВводаНачалоВыбора(Элемент, СтандартнаяОбработка)
ФормаПодбора = Справочники.Склад.ПолучитьФормуВыбора();
ФормаПодбора.МножественныйВыбор = Истина;
ФормаПодбора.ВладелецФормы = Элемент;
    ФормаПодбора.Открыть();
КонецПроцедуры


LexaK

вообще, этот механизм называется Подбором,
как правило, вешается на кнопку Подбор 
вызывается форма выбора/подбора, пример
&НаКлиенте
Процедура Подобрать(Команда)

Если ЗначениеЗаполнено(ВладелецОтбор) Тогда
Отбор = Новый Структура("Владелец", ВладелецОтбор);
ПараметрыФормы = Новый Структура;
ПараметрыФормы.Вставить("ЗакрыватьПриВыборе",Ложь);
ПараметрыФормы.Вставить("МножественныйВыбор",Истина);
ПараметрыФормы.Вставить("РежимВыбора",Истина);
ПараметрыФормы.Вставить("Отбор",Отбор);
Иначе
ПараметрыФормы = Новый Структура("ЗакрыватьПриВыборе, МножественныйВыбор, РежимВыбора", Ложь, Истина, Истина);
КонецЕсли;

ОткрытьФорму(ПолноеИмяОбъекта + ".ФормаВыбора",ПараметрыФормы,ЭтаФорма,,,,,РежимОткрытияОкнаФормы.БлокироватьОкноВладельца);

КонецПроцедуры

и создаете обработчик события формы ОбработкаВыбора с такой процедурой, пример
&НаКлиенте
Процедура ОбработкаВыбора(ВыбранноеЗначение, ИсточникВыбора)

Если ЗначениеЗаполнено(ВыбранноеЗначение) Тогда
Для Каждого Значение Из ВыбранноеЗначение Цикл
НоваяСтрока = СписокЗначенийОтбора.Добавить();
НоваяСтрока.ЗначениеОтбора = Значение;
НоваяСтрока.Пометка = Истина;
КонецЦикла;
КонецЕсли;

КонецПроцедуры

ответ Понравился? (в смысле пригодился?)

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск