Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
23 сен 2021, 15:34

ошибка при открытии внешнего отчета!

Автор VID1234, 15 сен 2021, 10:00

0 Пользователей и 1 гость просматривают эту тему.

VID1234

Здравствуйте. Подскажите, почему при открытии отчета на толстом клиенте, все норм, а при открытии на тонком клиенте пишет: {ОбщаяФорма.ФормаОтчета.Форма(751,22)}: Тип не определен (КонструкторСхемыКомпоновкиДанных), что это может быть?

VID1234

Вопрос решен, добавил это:
Процедура ОпределитьНастройкиФормы(Форма, КлючВарианта, Настройки) Экспорт
Настройки.ФормироватьСразу = Истина;
Настройки.События.ПриСозданииНаСервере = Истина;
КонецПроцедуры

Процедура ПриСозданииНаСервере(Форма, Отказ, СтандартнаяОбработка) Экспорт
ОбъектыНазначения = ОбщегоНазначенияКлиентСервер.СвойствоСтруктуры(Форма.Параметры, "ОбъектыНазначения");
Если ОбъектыНазначения <> Неопределено Тогда
Форма.ФормаПараметры.УстановитьЗанчениеПараметра("Регистратор", ОбъектыНазначения);
КонецЕсли;
КонецПроцедуры

и все заработало!

alexandr_ll

Данный отчет предназначен только для работы на толстом клиенте, либо должен быть переписан код

VID1234

@alexandr_ll, я уже решил, спасибо! А какой код то? у меня только одна (теперь правда 3 процедуры) которые универсальные

VID1234

 Спасибо! Вопрос закрыт! Всем добра, голосуем не за ЕР!

alexandr_ll

@VID1234, Ну, пока писал ответ, вы уже исправили. Вы же изменили код (добавили процедуры), точнее не видя самого отчета подсказать было трудно.

VID1234


Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск