Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
27 сен 2021, 18:19

Вывод стандартной кнопки "Печать" в созданный документ конфигурации

Автор SoOliateR, 13 сен 2021, 12:54

0 Пользователей и 1 гость просматривают эту тему.

SoOliateR

Подскажите, почему не выводится стандартная кнопка печать"?  1С:Управление торговлей (11.4.11.106)
Общий модуль "УправлениеПечатьюУтСервер":
Процедура ОпределитьОбъектыСКомандамиПечати(СписокОбъектов) Экспорт

   СписокОбъектов.Добавить(Документы.БланкПостановкиЗадач);

КонецПроцедуры

В модуль менеджера добавил код:

Процедура ДобавитьКомандыПечати(КомандыПечати) Экспорт
   
   // БПЗ
   КомандаПечати = КомандыПечати.Добавить();
   КомандаПечати.МенеджерПечати = "Документ.БланкПостановкиЗадач";
   КомандаПечати.Идентификатор = "ПФ_MXL_БПЗ";
   КомандаПечати.Представление = НСтр("ru = 'БПЗ'");
            
КонецПроцедуры


Процедура Печать(МассивОбъектов, ПараметрыПечати, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт
   
   Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "БПЗ") Тогда
      УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(
         КоллекцияПечатныхФорм,
         "БПЗ",
         ,
         СформироватьПечатнуюФормуБПЗ(МассивОбъектов[0], ОбъектыПечати));
      КонецЕсли;

КонецПроцедуры

Функция СформироватьПечатнуюФормуБПЗ(СсылкаНаОбъект, ОбъектПечати)   ту тоже селал, указал что где печатать.

В форму документа добавил:

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
      // СтандартныеПодсистемы.ПодключаемыеКоманды
   ПодключаемыеКоманды.ПриСозданииНаСервере(ЭтотОбъект);
   // Конец СтандартныеПодсистемы.ПодключаемыеКоманды
   
   
   // СтандартныеПодсистемы.ВерсионированиеОбъектов
   ВерсионированиеОбъектов.ПриСозданииНаСервере(ЭтотОбъект);
   // Конец СтандартныеПодсистемы.ВерсионированиеОбъектов


КонецПроцедуры


Процедура ПриЧтенииНаСервере(ТекущийОбъект)
   // СтандартныеПодсистемы.УправлениеДоступом
   Если ОбщегоНазначения.ПодсистемаСуществует("СтандартныеПодсистемы.УправлениеДоступом") Тогда
      МодульУправлениеДоступом = ОбщегоНазначения.ОбщийМодуль("УправлениеДоступом");
      МодульУправлениеДоступом.ПриЧтенииНаСервере(ЭтотОбъект, ТекущийОбъект);
   КонецЕсли;
   // Конец СтандартныеПодсистемы.УправлениеДоступом
      // СтандартныеПодсистемы.ДатыЗапретаИзменения
   ДатыЗапретаИзменения.ОбъектПриЧтенииНаСервере(ЭтотОбъект, ТекущийОбъект);
   // Конец СтандартныеПодсистемы.ДатыЗапретаИзменения
   
   
   
   // СтандартныеПодсистемы.ПодключаемыеКоманды
   ПодключаемыеКомандыКлиентСервер.ОбновитьКоманды(ЭтотОбъект, Объект);
   // Конец СтандартныеПодсистемы.ПодключаемыеКоманды

КонецПроцедуры


#Область СлужебныеПроцедурыИФункцииБСП

// СтандартныеПодсистемы.ПодключаемыеКоманды
&НаКлиенте
Процедура Подключаемый_ВыполнитьКоманду(Команда)
   ПодключаемыеКомандыКлиент.ВыполнитьКоманду(ЭтотОбъект, Команда, Объект);
КонецПроцедуры

&НаСервере
Процедура Подключаемый_ВыполнитьКомандуНаСервере(Контекст, Результат) Экспорт
   ПодключаемыеКоманды.ВыполнитьКоманду(ЭтотОбъект, Контекст, Объект, Результат);
КонецПроцедуры

&НаКлиенте
Процедура Подключаемый_ОбновитьКоманды()
   ПодключаемыеКомандыКлиентСервер.ОбновитьКоманды(ЭтотОбъект, Объект);
КонецПроцедуры
// Конец СтандартныеПодсистемы.ПодключаемыеКоманды

#КонецОбласти




В итоге все равно в документе на форме нет кнопки "Печать" Что еще нужно добавить?




Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск