Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
27 сен 2021, 18:58

Изменение данных в печатной форме

Автор Bredmon, 10 сен 2021, 09:12

0 Пользователей и 1 гость просматривают эту тему.

Bredmon

Здравствуйте!
Есть задача, пользователь в печатной форме вводит суммы, которые должны изменять общую сумму в этой же печатной форме. Никаких изменений в базе быть не должно - распечатали и забыли.
В печатной форме создал область, в каждой ячейке установил флажок "СодержитЗначение" и задал тип значения "Число". В коде написал так
ТабДок.Область("R27C9:R64C10").ЭлементУправления.УстановитьДействие("ПриИзменении",новый Действие("ПриИзмененииЗначения"));


Процедура ПриИзмененииЗначения (ТабДок, СуммаВыплат) Экспорт
НомЯч = 27;
СуммаВыплат = 0;
Пока НомЯч < 65 Цикл
Ячейка = ТабДок.Область("R"+НомЯч+"C9:R"+НомЯч+"C10");
Если не Ячейка.Значение.Пустая() Тогда
СуммаВыплат = СуммаВыплат + Ячейка.Значение;
КонецЕсли;
        НомЯч = НомЯч + 1;
КонецЦикла;

КонецПроцедуры

Но выходит ошибка "Поле объекта недоступно для чтения (ЭлементУправления)".
Вопрос: как прописать вызов процедуры при изменении значений в области?

alexandr_ll

Цитата: Bredmon от 10 сен 2021, 09:12Здравствуйте!
Есть задача, пользователь в печатной форме вводит суммы, которые должны изменять общую сумму в этой же печатной форме. Никаких изменений в базе быть не должно - распечатали и забыли.
В печатной форме создал область, в каждой ячейке установил флажок "СодержитЗначение" и задал тип значения "Число". В коде написал так
ТабДок.Область("R27C9:R64C10").ЭлементУправления.УстановитьДействие("ПриИзменении",новый Действие("ПриИзмененииЗначения"));


Процедура ПриИзмененииЗначения (ТабДок, СуммаВыплат) Экспорт
НомЯч = 27;
СуммаВыплат = 0;
Пока НомЯч < 65 Цикл
Ячейка = ТабДок.Область("R"+НомЯч+"C9:R"+НомЯч+"C10");
Если не Ячейка.Значение.Пустая() Тогда
СуммаВыплат = СуммаВыплат + Ячейка.Значение;
КонецЕсли;
        НомЯч = НомЯч + 1;
КонецЦикла;

КонецПроцедуры

Но выходит ошибка "Поле объекта недоступно для чтения (ЭлементУправления)".
Вопрос: как прописать вызов процедуры при изменении значений в области?
https://helpf.pro/help/view/11815.html

Bredmon

@alexandr_ll, то есть, если я правильно понял, действие вообще прописывать не надо? Достаточно оставить процедуру, а в качестве параметра задать область в которую вносятся изменения?

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск