Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
25 сен 2021, 01:10

Регистр сведений с булевым ресурсом.

Автор Damnedbac, 27 авг 2021, 14:44

0 Пользователей и 1 гость просматривают эту тему.

Damnedbac

Добрый день. Только не давно начала осваивать 1с прошу помощи в решении задачи. Заранее спасибо.
Есть периодический(период 1 день) Регистр сведений с измерением "Машина" и с булевым ресурсом "Занятость".
Есть документ с реквизитом "Машина" (элемент справочника Транспортные средства) и "Дата отправки".
Как в документе выбирать только те "Машины", которые отсутствуют в регистре на дату отправки?

LexaK

вот примерный код, как сформировать для выбора список  свободных Машин
элементу формы Машина, назначить обработчик события НачалоВыбора
у поля поставить галочку Выбор из списка, и чего там еще

&НаКлиенте
Процедура МашинаНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)

ЗаполнитьСписокМашин();

КонецПроцедуры


&НаСервере
Процедура ЗаполнитьСписокМашин()

лкСписок = Элементы.Машина.СписокВыбора;
лкСписок.Очистить();

лкДанные = РегистрыСведений.КурсыВалют.СрезПоследних(,);
Для каждого лкСтр Из лкДанные Цикл
Если лкСтр.Занятость = Ложь Тогда
лкСписок.Добавить(лкСтр.Машина);
КонецЕсли;
КонецЦикла;

КонецПроцедуры
 
ответ Понравился? (в смысле пригодился?)

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск