Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
19 окт 2021, 11:32

Выгрузка значений из регистра сведений для списка выбора на форме

Автор Morikama, 21 авг 2021, 08:58

0 Пользователей и 1 гость просматривают эту тему.

Morikama

Друзья, привет! Как реализовать возможность выбора значения из списка в определённом реквизите формы с выгрузкой значений из регистра сведений?

Вот такой код молчит, ничего не происходит:
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| DCS.НомерРейса КАК НомерРейса
|ИЗ
| РегистрСведений.DCS КАК DCS";

РезультатЗапроса = Запрос.Выполнить();

ВыборкаДетальныеЗаписи = РезультатЗапроса.Выгрузить();

В свойствах поля, в событиях привязал эту обработку к "НачалоВыбораИзСписка".

LexaK

все понятно, простенькая задачка, осталось указать самое главное, в каком режиме 1С предприятие работает
Толстый или тонкий клиент, какие формы Обычные или управляемые, что в режиме совместимости, что в режиме использования синхронных вызовов?

(для всех этих вариантов разные команды могут использоваться)
ответ Понравился? (в смысле пригодился?)

Morikama

@LexaK, тонкий клиент, управляемая форма, Версия 8.3.16

LexaK

@Morikama, примерно такой код в форму вставьте

и в конструкторе формы не поле НомерРейса, Обязательно назначьте этот обработчик события ПриНачалеВыбора !!!

&НаКлиенте
Процедура НомерРейсаНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
ПолучитьЗначенияДляВыбора();
КонецПроцедуры

&НаСервере
Процедура УстановитьСписокВыбора();


лкЗапрос = Новый Запрос;
лкЗапрос.Текст = "
    лкЗапрос.Текст =
        |ВЫБРАТЬ различные
        |    DCS.НомерРейса КАК НомерРейса
        |ИЗ
        |    РегистрСведений.DCS КАК DCS
    |";


лкСписок = Элементы.НомерРейса.СписокВыбора;
лкСписок.Очистить();

лкВыборка = лкЗапрос.Выполнить().Выбрать();
Пока лкВыборка.Следующий() Цикл
лкСписок.Добавить(лкВыборка.НомерРейса);
КонецЦикла;

КонецПроцедуры

ответ Понравился? (в смысле пригодился?)

Morikama

@LexaK, да, так работает,список выдаёт, спасибо. Там ещё надо было, оказывается, галочку поставить в "РежимВыбораИзСписка" в Использовании.

Теги: выгрузка 

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск