Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
28 окт 2021, 13:38

Как вывести 4 строки таблицаы в 4

Автор lolmatrix, 12 авг 2021, 16:46

0 Пользователей и 1 гость просматривают эту тему.

lolmatrix

Здравствуйте, управляемые формы 1с 8.3.18.1289, подскажите пожалуйста новичку как реализовать вывод 4- х строк на печать  из табличной части документа в четырех углах листа четыре этикетки, каждая строка  табличной части - одна этикетка, ничего придумать не получается, посоветуйте как возможно это сделать если возможно,заранее спасибо

alexandr_ll

Рисуете макет с четырьмя этикетками, в каждой задаете параметры 1, 2,3 и 4. В модуле в цикле задаете значение этих параметров. Выводите макет на печать.

LexaK

предлагаю другой вариант
с ОДНИМ макетом этикетки, просто вывести его 4 раза!

(у кого еще какие варианты есть?)
ответ Понравился? (в смысле пригодился?)

lolmatrix

@LexaK, @LexaK, так в том-то и дело чо все 4 на одном листе должны быть и в них 4 строки табличной части

lolmatrix

@alexandr_ll, спасибо. ваш ответ натолкнул на  мою ошибку в реализации именно  этой схемы решения. работает, теперь вопрос как реализовать с 5-й строки   и этикетки по остальные на других листах

LexaK

@lolmatrix, куда-то пропало сообщение, это повтор,

попробуйте такой код, только свои наименования подставьте

ТабДок = Новый ТабличныйДокумент;
//или "Этикетка|Колонка" - именно прямоушольная область нужна
ОблЭтикетки = Макет.ПолучитьОбласть("Этикетка");
лкСчетчик = 0;
Для каждого лкСтр Из ВашаТЧ Цикл

лкСчетчик = лкСчетчик + 1;
ОблЭтикетки.Параметры.Заполнить(лкСтр);

Если (лкСчетчик % 4) = 0 Тогда
//порции по 4 штуки, можно выйти, а зачем?
//если этикеток много продолжаем печатать на других листах
//вставляем разделитель
ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
КонецЕсли;

//определяем режим вывода: нечет - выводим, чет - присоединяем
//получается 2 этикетки в ряд
Если (лкСчетчик % 2) = 0 Тогда
ТабДок.Присоединить(ОблЭтикетки);
Иначе
ТабДок.Вывести(ОблЭтикетки);
КонецЕсли;

КонецЦикла;
ответ Понравился? (в смысле пригодился?)

lolmatrix

@LexaK,  извините можете пояснить, свой код он выводит последовательно строки, а мне нужно в 4-х местах листа

LexaK

@lolmatrix, чуть по позже напишу пример обработки с выводом 4-х этикеток на страницу
(надеюсь) вам проще будет понять как это работает на работающем примере
ответ Понравился? (в смысле пригодился?)

lolmatrix

@LexaK, спасибо, буду очень благодарен

LexaK

уточните в каком режиме у вас 1С работает
в Управляемом
или в Обычном ?
ответ Понравился? (в смысле пригодился?)

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск