Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
27 сен 2021, 19:08

Заполнение поля формы на подразделения, в зависимости от другого поля!

Автор VID1234, 10 авг 2021, 14:57

0 Пользователей и 1 гость просматривают эту тему.

VID1234

Здравствуйте. Не выводится значение в поле формы документа "ПодразделениеОтправитель".
&НаСервереБезКонтекста
Функция ЦМООтправительПриИзмененииНаСервере(Знач ЦМООтправитель)
Запрос = Новый Запрос(
"ВЫБРАТЬ
    |ЦМО.Ссылка КАК Ссылка,
    |ЦМО.Наименование КАК Наименование,
    |ЦМО.Сотрудник КАК Сотрудник,
    |ЦМО.МестоХранения КАК МестоХранения
    |ИЗ
    | Справочник.ЦМО КАК ЦМО
    |ГДЕ
    |    ЦМО.Ссылка = &Ссылка");   
   
    Запрос.УстановитьПараметр("Ссылка", ЦМООтправитель);
   
    РеквизитыПолучателя = Новый Структура("МестоХранения");
   
    Выборка = Запрос.Выполнить().Выбрать();
   
    Если Выборка.Следующий() Тогда
       
        ЗаполнитьЗначенияСвойств(РеквизитыПолучателя, Выборка);
       
    КонецЕсли;   
   
    Возврат РеквизитыПолучателя;

   
КонецФункции

&НаКлиенте
Процедура ЦМООтправительПриИзменении(Элемент)
   
    РеквизитыКонтрагента = ЦМООтправительПриИзмененииНаСервере(Объект.ЦМООтправитель);
    Объект.ПодразделениеОтправитель = РеквизитыКонтрагента.МестоХранения;

КонецПроцедуры
Отладчиком прохожу, все норм (Объект.ПодразделениеОтправитель = РеквизитыКонтрагента.МестоХранения;(здесь справа от равенства, то значение, которое нужно), но значение в поле не проставляется! Почему??

ef0din


VID1234

@ef0din, ЦМООтправитель.МестоХранения - СправочникСсылка.МестаХранения, а у ПодразделениеОтправитель - СправочникСсылка.Подразделения

antoneus

А делается все гораздо проще и без кода. И лишний реквизит заводить не надо.

ef0din

Цитата: VID1234 от 10 авг 2021, 15:29@ef0din, ЦМООтправитель.МестоХранения - СправочникСсылка.МестаХранения, а у ПодразделениеОтправитель - СправочникСсылка.Подразделения

Так потому и не подставляется, что типы значений разные.

VID1234


VID1234

@VID1234, Решил, добавил реквизит подразделение на форму ЦМО, после этого с помощью запроса выдернул этот реквизит  (Где ссылка = &ссылка, а параметр ссылка, это поле ЦМООтправитель) в результате все получилось!  Создал правда в расширении модуль с вызовом сервера, туда поместил функцию с запросом, а уже также через расширение вызывал эту функцию с модуля формы, где передавал значение ЦМООтправитель.

antoneus

А делается все гораздо проще и без кода и запросов. И лишний реквизит в документе заводить не надо.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск