Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
27 сен 2021, 20:04

Как связать справочник и реквизиты.

Автор NepomAR, 04 авг 2021, 21:29

0 Пользователей и 1 гость просматривают эту тему.

NepomAR

Здравствуйте! Только учусь и пытаюсь разбираться в 1С, много не понимаю. Подскажите пожалуйста, есть задание.
Есть Справочник"Номенклатура" в нем есть реквизит "Серия по умолчанию", и так же есть справочник. При заполнении документа при выборе номенклатуры нужно заполнять серию значением по умолчанию. Вопрос, не пойму как это все можно связать и сделать это запросом. Буду очень благодарна за пояснение 

Ивашка

Цитата: NepomAR от 04 авг 2021, 21:29Здравствуйте! Только учусь и пытаюсь разбираться в 1С, много не понимаю. Подскажите пожалуйста, есть задание.
Есть Справочник"Номенклатура" в нем есть реквизит "Серия по умолчанию", и так же есть справочник. При заполнении документа при выборе номенклатуры нужно заполнять серию значением по умолчанию. Вопрос, не пойму как это все можно связать и сделать это запросом. Буду очень благодарна за пояснение 
примерно так:
&НаКлиенте
Процедура НоменклатураПриИзменении(Элемент)
    Строка = Элементы.ИмяТЧДокумента.ТекущиеДанные;
    Строка.Серия = ПолучитьРеквизит(Строка.Номенклатура);
КонецПроцедуры
 
&НаСервереБезКонтекста
Функция ПолучитьРеквизит(Номенклатура)
    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |    Номенклатура.Серия
        |ИЗ
        |    Справочник.Номенклатура КАК Номенклатура
        |ГДЕ
        |    Номенклатура = &Номенклатура";
    Запрос.УстановитьПараметр("Номенклатура",Номенклатура);
    РезультатЗапроса = Запрос.Выполнить().Выбрать();
    Пока РезультатЗапроса.Следующий() Цикл
        Возврат РезультатЗапроса.Серия;
    КонецЦикла;
КонецФункции

antoneus

Еще раз: не надо создавать в документах реквизиты для хранения реквизитов других реквизитов :)
В документе хранится ссылка на элемент справочника, которая при желании дает доступ к значениям всех его реквизитов и дублировать информацию не надо. А если в номенклатуре изменится значение этой самой серии по умолчанию - вы будете во всех документах ее изменять? Если надо отображать эту серию на форме - мышкой раскройте в редакторе формы номенклатуру и перетащите реквизит на форму документа. При изменении номенклатуры серия будет перезаполняться сама как по волшебству.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск