Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Янв 2018, 07:07
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: помогите разбораться в обработке документов "ЗаказТоваров"  (Прочитано 8157 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн proofet

  • **
  • Сообщений: 66
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-11
  • Сайт: 
  • Профессия: Ученик 1С
Всем привет! :mellow:. Столкнулся с проблемой в следующем задании: Нужно  составить новый документ ЗаказТоваров. Смысл в том, что можно указывать те товары, которые мы у поставщика заказали.  товары приходят через неделю после даты составления документа. также присутствует реквизит "товар уже пришел" (Документ "ЗаказаТоваров" создает движения в регистре накоплений "ТоварыВПути", но это не обязательный пункт прост мне кажется так проще далее). И далее уже нужно создать обработку, которая будет искать все "просроченные" документы заказтоваров (кнопка ПОИСК). Она должна выводить документы в табличную часть (ТабличноеПоле). Пользователь должен иметь возможность галочками указать по каким документам товар пришел, а по каким нет (отдельная колонка с галочкой). По всем тем, по которым пришел товар, обработка должна заводить на основании документ поступления (проводить по регистрам накопления, если товар пришел - истина).

начал было так делать....но не получается заполнить ТЧ в форме обработки ....
ДокВыборка = Документы.ЗаказТоваров.Выбрать();
    Пока ДокВыборка.Следующий() Цикл
        Если ДокВыборка.Проведен Тогда
            Документ = ДокВыборка.ПолучитьОбъект();
          Если Документ.ДатаПрихода < ТекущаяДата() Тогда
            ЭлементыФормы.ТабличноеПолеЗаказыТоваров.Значение = Документ.Прочитать();
            Если ЭлементыФормы.ТабличноеПолеЗаказыТоваров.Колонки.Пришёл = Истина Тогда
// и вот что и как далее я хз



может хоть намекнете на правильное решение, не прошу весь код писать.....Просто хочется разобраться в процессе...


Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Посоветовала бы запрос написать. Документов со временем может быть много, и обходить их таким образом будет затруднительно.
По заполнению табличной части. Если есть Док1 и Док2, нужно из таб.части Док1 перенести товары в таб.часть Док2, то делаем так:
ТабЧасть=Док2.ТабЧасть;
Для каждого Строка из Док1.ТабЧасть цикл
       НоваяСтрока=ТабЧасть.Добавить();
       НоваяСтрока.Номенклатура=Строка.Номенклатура;
       НоваяСтрока.Количество=Строка.Количество;
       // ну и так далее по нужным колонкам
КонецЦикла;
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Если нужны все колонки перенести, я обычно одной строкой пишу...

ЗаполнитьЗначенияСвойств(НоваяСтрока,Строка);
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
По задаче...

Просроченные документы выбирайте запросом.
При обходе результата запроса...

НоваяСтрока = ТЗПросроченныеЗаказы.Добавить();
НоваяСтрока.Заказ = ВыборкаИзЗапроса.Ссылка;
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн proofet

  • **
  • Сообщений: 66
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-11
  • Сайт: 
  • Профессия: Ученик 1С
Спасибо большое дорогие товарищи!))

Оффлайн proofet

  • **
  • Сообщений: 66
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-11
  • Сайт: 
  • Профессия: Ученик 1С
С заполнение вроде разобрался (учитывая ваши советы сделал запрос). Теперь проблема в следующем ...."Пользователь должен иметь возможность галочками указать по каким документам товар пришел, а по каким нет (отдельная колонка с галочкой). По всем тем, по которым пришел товар, обработка должна заводить на основании документ поступления (проводить по регистрам накопления, если товар пришел - истина)."              ..В ТЧ добавил реквизит с типом булево "Пришел"....как связать этот реквизит и документ которому пренадлежит строка?...т.е. у меня ТЧ заполняется и в каждой строке есть реквизит булево "Пришел". После нажатия отдельной кнопки "Провести", по тем строкам (документам) где булево=истина, вся номенклатура в документе проводится по отдельному регистру накопления.........Как это осуществить друзья ?(

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Для каждого ТекСтрокаТЧ Из ТЧ Цикл
Если ТекСтрокаТЧ.Пришел Тогда
...
КонецЕсли;
КонецЦикла;
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн proofet

  • **
  • Сообщений: 66
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-11
  • Сайт: 
  • Профессия: Ученик 1С
№ ДатаСоздДок.  ДатаПрихода    Пришёл
1    19.03.11           31.03.11           []


/\
||

Так примерно выгляди ТЧ на форме...

При обходе ТекСтрокаТЧ Из ТЧ ...как получить ссылку на этот документ не совсем понимаю ?...эж просто строка..без ссылки(( или я что то не понимаю....,Как мне провести эту строку по регистру ?.

Оффлайн proofet

  • **
  • Сообщений: 66
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-11
  • Сайт: 
  • Профессия: Ученик 1С
 Процедура ПоискНажатие(Элемент)
   
    Запрос = Новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ
                   |    ЗаказТоваров.ДатаПрихода КАК ДатаПрихода,
                   |    ЗаказТоваров.Дата КАК Дата
                   |ИЗ
                   |    Документ.ЗаказТоваров КАК ЗаказТоваров
                   |ГДЕ
                   |    ЗаказТоваров.ДатаПрихода < &ТекущаяДата
                   |    И ЗаказТоваров.ПометкаУдаления = ЛОЖЬ";
    Запрос.УстановитьПараметр("ТекущаяДата", ТекущаяДата());
    Результат = Запрос.Выполнить();
    Выборка = Результат.Выбрать();
   
    Пока Выборка.Следующий() Цикл
        НоваяСтрока = Товары.Добавить();
        НоваяСтрока.ДатаПрихода = Выборка.ДатаПрихода;
        НоваяСтрока.ДатаСоздания = Выборка.Дата;
    КонецЦикла;
   
   
КонецПроцедуры

...........................


№ ДатаСоздДок.  ДатаПрихода    Пришёл
1    19.03.11           31.03.11           []


После заполнения так примерно выглядит ТП
...............................................................
Процедура ПровестиНажатие(Элемент)
    Для каждого ТекСтрокаТовары Из Товары Цикл
        Если ТекСтрокаТовары.Пришел=Истина
            Тогда

  // нужно провести этот документ по регистру.....(ну тот чьи даты заполнили строку ТП)

КонецЕсли;
КонецЦикла;

Оффлайн proofet

  • **
  • Сообщений: 66
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-11
  • Сайт: 
  • Профессия: Ученик 1С
Собсно вся сложность в номенклатуре документа....В ТП я её не заполнил.......И откуда тогда её получить ? и можно ли вообще как то её достать ? или мне что то поменять? :dfbsdfbsdf:


Теги:
 

Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5648
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5977
Последний ответ 28 Мар 2012, 13:02
от chum710
Запрос на перенос срока задачи НЕ автору задачи, а другому пользователю. Помогите с конфигурированием!

Автор juli777Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1910
Последний ответ 18 Ноя 2014, 21:14
от sertak
ошибка в программе,помогите пожалуйста,кто-то сталкивался с такой ошибкой-не удалось определить имя ответственного сотрудника

Автор Татьяна RhsvРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1810
Последний ответ 17 Окт 2014, 15:57
от cska-fanat-kz
Народ помогите пожалуйста создать внешнюю обработку для корректной работы галки (входит в холдинг)

Автор White_SharkРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1359
Последний ответ 15 Май 2015, 09:23
от White_Shark

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
102 Сообщений
AIFrame
86 Сообщений
alex0402
34 Сообщений
pavl_vs
23 Сообщений
kiksi
19 Сообщений
alexandr_ll
17 Сообщений
andron81_81
16 Сообщений
Norfolk
15 Сообщений
LexaK
13 Сообщений
Artibon
13 Сообщений

* Кто онлайн

  • Точка Гостей: 380
  • Точка Скрытых: 0
  • Точка Пользователей: 10
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal